Support » Networking WordPress » Unmap a site

  • Resolved patbell101

    (@patbell101)



    I have a site mapped to photoclubmeteorite.org. I need to change it back to photoclubmeteorite.patbell.co.uk but because the domain has expired I can’t edit the site from MySites. On a single site I can do this in wp-config but in a multisite I presume I need to edit the database. What table is the site url info?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • RossMitchell

    (@rossmitchell)

    If you put the lapsed domain name into your hosts file, then the hosting will not realize that the DNS system is not being used, it will just respond.
    Details on the hosts file here:
    https://en.wikipedia.org/wiki/Hosts_(file)

    patbell101

    (@patbell101)

    Great. Thanks.

    patbell101

    (@patbell101)

    Sorry, it isn’t working. Perhaps I have misunderstood.

    I have a subdomain photoclubmeteorite.patbell.co.uk mapped to photoclubmeteorite.org

    In hosts.txt I have tried

    108.167.137.112 http://photoclubmeteorite.org
    or
    127.00.00.01 http://photoclubmeteorite.org

    but if I try http://photoclubmeteorite.patbell.co.uk/wp-admin it resolves as
    http://photoclubmeteorite.org/wp-admin and is not found.

    Is there something further I need to do in wp-options?

    RossMitchell

    (@rossmitchell)

    Yes you have misunderstood.

    <sermon>As an aside in future please be sure to use the “code” setting to quote blocks of text so that unfortunate text changes do not occur.
    In particular there are no “http://” stuff, the “hosts” file is about domain names, the “<letters>://” bit is about protocol (and ports) which is a different thing.</sermon>

    Your problem is that you want an expired domain name to map to your multisite server. What is the IP address of this server ? (If it is localhost then it is 127.0.0.1) for the sake of this tutorial lets say the IP address is a.b.c.d where abcd are all numbers.

    From the webpage I gave you need to find where and what the “hosts” file lives on your OS.
    Using a regular text editor (not WORD or some wysiwyg) add this line:
    a.b.c.d photoclubmeteorite.patbell.co.uk
    And save it.
    This will tell your browser that the website: “http://photoclubmeteorite.patbell.co.uk/” is to be mapped to IP address a.b.c.d
    The request will arrive at that server just like any web request, the server will not know that the DNS system was not consulted, nor that the name is expired.

    Though I have never experienced this I understand that the chrome browser on mac OS does not use the hosts file. So in this case you would have to do something different.

    patbell101

    (@patbell101)

    I actually solved my problem by another means. By using Network dashboard – sites one can edit the url of the problem subdomain. Voila. unmapped.

    Possibly I hadn’t described my problem correctly

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.