WordPress.org

Forums

All in One SEO Pack
[resolved] Universal Analytics not working (47 posts)

  1. dr.user
    Member
    Posted 1 year ago #

    Sorry, I'm unable to post a URL... I'll just disable the aio analytics portion, and add the tracking code directly to the header.

    Thanks for the input.

  2. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    Ok; let me know if you find a difference in the two tracking codes that'd be useful to us, really, this should work.

  3. dr.user
    Member
    Posted 1 year ago #

    O.K. Peter... I "think" I've sorted this out both manually and plugin. If you still receive this message:

    "Your Analytics tracking code does not include the necessary support"

    Or it doesn't validate, Select "Skip Validation" this "seems" worked for me!

    No data yet and states the following:
    "Demographics: Overview
    Some data in this report may have been removed when a threshold was applied. Learn more"

    So we'll see if it starts showing data. I'll keep an eye on it

    Thanks.

  4. carodani
    Member
    Posted 1 year ago #

    I wonder why activating the universal on the plugin I get the demographic but the bounce rate goes from a 90% circa to 10%...
    Is that a bug?

    http://www.scotoutdoors.com

    No double code in it

  5. ribit1
    Member
    Posted 1 year ago #

    I checked the code created by all in one and it is not what Google said it should be. After the UA code it should say 'auto' and it doesn't. I'm wondering if that is what is causing the issue.

  6. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    Hi ribit1,

    If that's what you're using, put in auto for your domain, then.

  7. carodani
    Member
    Posted 1 year ago #

    Peter do you confirm your plugin does not generate what Google said it should be?
    Because in this case I am not going to trust your plugin altogether, that would be a really bad behaviour.

    Please just confirm or deny, an explanation is needed.

    Thanks

  8. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    carodani,

    All in One SEO Pack generates complaint Google Analytics code based on the plugin settings; one of these settings is the domain, and one of the possible settings is auto - we support this. There is no one true Google Analytics tracking code, it is customizable, which is why we have options for it.

  9. ankurZ
    Member
    Posted 8 months ago #

    Guys help me remove this line from the top of my homepage:
    ga('require', 'displayfeatures');

    Check on http://www.koshurbaazar.in/

  10. wpsmort
    Support Manager at Semper Fi
    Posted 8 months ago #

    Go to All in One SEO, General Settings, Google Settings and uncheck the Display Advertising Tracking box.

    Here you go - http://semperplugins.com/documentation/advanced-google-analytics-settings/#displayadvertisingtracking

  11. ankurZ
    Member
    Posted 8 months ago #

    @wpsmort, done that but it's still there.
    Made my settings exactly like you suggested but
    ga('require', 'displayfeatures'); is not getting removed.

  12. wpsmort
    Support Manager at Semper Fi
    Posted 8 months ago #

    Where do you see it? Here's the tracking code from your site and I don't see it anywhere:

    <!-- All in One SEO Pack 2.2.3.1 by Michael Torbert of Semper Fi Web Design[109,128] -->
    <link rel="canonical" href="http://www.koshurbaazar.in/" />
    			<script>
    			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    
    			ga('create', 'UA-55661326-1', { 'allowLinker': true } );
    
    			ga('send', 'pageview');
    			</script>
    <!-- /all in one seo pack -->
  13. ankurZ
    Member
    Posted 8 months ago #

    Yaa i can't see it in my tracking code but still on my homepage's UI it's showing that is why it is so strange.

  14. wpsmort
    Support Manager at Semper Fi
    Posted 8 months ago #

    You have caching enabled, try clearing your cache.

  15. ankurZ
    Member
    Posted 8 months ago #

    done that too, still there!

  16. wpsmort
    Support Manager at Semper Fi
    Posted 8 months ago #

    I'm not really able to help you any further. You've clearly unchecked that option in All in One SEO Pack and the code related to that option is definitely not in your tracking code any more so All in One SEO Pack is working fine. If there's still a problem then its with caching or something else.

  17. ankurZ
    Member
    Posted 8 months ago #

    Okay thanks a ton anyway! will do some troubleshooting

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • All in One SEO Pack
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic