Support » Plugin: CoursePress Learning Management System » Units cannot be saved

  • Resolved lekjaz

    (@lekjaz)


    I have coursepress installed on a new/clean installation of wordpress with the default theme and no other plugins (besides Marketpress, which you recommended). I am able to create a course and save it, but when i create my first unit, I receive this error “Something went wrong. Unit was not saved!”. No combination of checking or unchecking boxes or filling in text in the required fields changes the outcome.

    I saw another user was having a similar issue, and the recommended action was to add some debugging code to wp-config, which I did. This problem doesn’t seem to generate a log event because that code produced no log file that I could find.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @lekjaz,

    Hope all is well!

    I can’t replicate the same. Would yu please try to toggle units and course from draft to live and try again?

    If the above will not solve the issue, would you try adding below a line of code in your wp-config.php file just above /* That’s all, stop editing! Happy blogging. */ line and see if it saves after that.
    @ini_set( 'post_max_size', '256M');

    Let me know how it goes!

    Cheers,
    Nastia

    Thread Starter lekjaz

    (@lekjaz)

    I have tried toggling on-off the Publish and Draft/Live toggles as you instructed. The Publish toggle works. The Draft/Live toggle does not work. It is stuck in the Draft position and cannot be changed even with multiple clicks.

    I added the code to wp-config.php as you instructed and refreshed the page and this did not change the error message or the non-functional Draft/Live toggle.

    since my situation has ruled out conflicts with plugins ans themes, is there a FAQ that lists the PHP requirements of the server needed to run this plugin? I’m wondering if there is something in the server that is preventing the plugin from running.

    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @lekjaz, hope you are doing well.

    It might be related to server settings. Would you please contact your host provider and ask if the PUT method is not allowed? If it is not, is is possible to change these settings and allow PUT method?

    The CoursePress should be working with all PHP versions, from PHP 5.2 to PHP 7.1.1. Please let me know what PHP version is running on your site?

    Kind regards,
    Nastia

    Plugin Author jdailey

    (@jdailey)

    Thank you for using CoursePress. I am going to mark this topic resolved because we haven’t heard from you in awhile. If this issue was not resolved we can reopen it. Thanks again!

    I haven’t received any help with this issue and continue to struggle – and lose business. After our recent CP update, the Quiz plugin does not work, and CP settings are all corrupted. i now have a tech team trying to figure it out, but cannot imagine I am the only one with this issue. I would like CP to interact with the tech team to help find a resolution, if possible. Thanks, Barb

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @brahmiknit,

    Sorry to hear you’re having issues with CP, can you please start new thread per forum rules and we will investigate this further.

    Thank you,
    Predrag

    Hi I ave the same problem, but I also have different pluggins installed. I checked wp-config.php and I have actual php version and I cannot save any Unit as a draft and as published as well.

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @alchemiaruchu,

    Could you please start a separate thread and in there include which PHP version you use, and also try disabling your plugins and switch to default WP theme to see if units are saving after that.

    That would help us with determining the cause so we can debug it further.

    Thank you,
    Predrag

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Units cannot be saved’ is closed to new replies.