Support » Fixing WordPress » Unique Image Uploading problem in 2.5.1

  • I am unable to upload anything through the post screen to my installation of WordPress 2.5.1. I have searched these forums, as well as Google and I haven’t found anyone else with the same issue. Here’s the story:

    The flash uploader loads like it usually does. I pick a file to upload (any size, small or large). I see the ‘crunching’ text, then I am taken to the page that normally shows up when an image is uploaded, with the details of the image. The title is in the title field, but the thumbnail is empty. (Empty in Firefox, broken image in Safari & IE7). I can insert into the Post, but it inserts a non-existant image. Any post that is saved and viewed just shows a broken image, or no image at all. No error is displayed at any time during the upload or insert process. Checking the uploads directory with FTP, there are no uploads.

    I’ve tried the following:

    • Fresh Install of WP 2.5.1
    • Fresh download and Fresh install of WP 2.5.1
    • All the various modifications to .htaccess
    • Permission set to 777
    • Creating a new /uploads directory and setting it to 777
    • Disabling the flash plugin, the basic plugin did not work either
    • Everything in Otto’s sticky post:

    To see if it was a PHP upload problem, and not a WordPress problem, I used a small php script to upload an image and output the results. That worked.

    I decided to try an earlier version of WordPress. I installed 2.3, and the upload worked as well. It is only 2.5.1.

    WordPress see’s it as a successful upload, but it never makes it into the upload folder. Anybody have any ideas?

    One other thing. The test domain they provided me with is 2 subdomains deep. ie… Could it be this?

    I have a request into the hosting provider to see if they have any ideas. They do a lot of business hosting, and they’re not cheap shared hosting, but I figured someone else must have installed WordPress on their servers at some point.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I am having a similar problem, I have posted about it here.

    Check your wp-admin folder and see if your uploads are ending up in there anywhere.

    Hi jleuze

    Thanks for the message. I thought I was the only one having this particular issue.

    I checked my wp-admin folder, and hey, there they all are!!


    Why are they going in there? told them to go to:


    Thanks for helping me find the images jleuze. Now I just need to solve why they are going in this folder.

    Hi luxcious, I’m glad to know that I’m not the only one having this issue either!

    I have tried and tried to change the upload directory in the settings. No matter what I enter for the paths, the files I upload end up on the wp-admin directory.

    I did discover that if I intentionally choose a path that is in the wp-admin folder, I can have some control over where those files land, but they are still in wp-admin.

    One time I even managed to see an image that I uploaded and add it to a draft. I think that the path that the uploader was using and the path where the file actually was just happened to match. But that was a fluke that I haven’t been able to reproduce, and isn’t exactly the kind of solution I want!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Unique Image Uploading problem in 2.5.1’ is closed to new replies.