WordPress.org

Support

Support » How-To and Troubleshooting » Unintelligible characters,- encoding issue???

Unintelligible characters,- encoding issue???

  • Hi

    One of my friends complained that my blog made his live bookmarks (Firefox) look wierd…some of the character became intelligible (apostrophs, quotations marks, periods etc etc).

    Like this:

    http://photos1.blogger.com/blogger/3784/10/1600/annoying_bookmarks.gif

    Also….if I copy/paste text from my blog and posts it on other site (e.g. a forum) the same characters gets messed up…Which is kinda annoying.

    The text encoding on my blog is set to: UTF-8

    Is it related to the text encoding or…? Any suggestions?

    Thx…appreciated!

Viewing 5 replies - 1 through 5 (of 5 total)
  • No one?

    I have noticed similar issues with Google Analytics, in which it lists two entries for some of my pages — once with the title interpreted properly, and a second time with entity codes for non-ascii characters in the title. I’ve no idea what’d be causing it (theoretically I’m serving up UTF-8), but you’re not alone in wondering what causes it.

    That’s a filter that WordPress uses – it changes certain things to character encoding. I can’t remember which one it is though – wither wpautop ot wptexturize. Look in your wp-includes folder for “default-filters.php” and look for those two filter types. The lines look something like this:

    add_filter(‘bloginfo’,’wp_specialchars’);

    Just comment them out, like so:

    //add_filter(‘bloginfo’,’wp_specialchars’);

    I think that might do it for ya. (Hopefully!)

    Thanks a lot doodlebee…as far as I can tell it solved the problem. Now that I’ve cemmented them out…Are there any “sideeffects”?

    Again..thx for helping out…appreciated!

    The only “side effects” I know of is that it doesn’t change things like the apostrophes and quotes to the character encoding numbers. As far as I’ve been able to tell, that’s the only purpose for the filter. Why? Dunno. Other side effects? I don’t think so – but I’m no expert 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Unintelligible characters,- encoding issue???’ is closed to new replies.
Skip to toolbar