Support » Installing WordPress » Unicode chinese turn into symbols after upgrade to wp2.2

  • elsewhere

    (@elsewhere)


    I am using unicode chinese input for my blog. It goes well with the previous version, but after i upgrade to 2.2 by Fantastico, all the chinese turn into unrecognizable texts!!!!!! How to solve this problem??????

Viewing 12 replies - 31 through 42 (of 42 total)
  • Thanks Moshu, I did read that and have solved the problem at one of my sites by removing 2 lines from config.php. I also read in this thread that there could be other issues caused by removing that 2 lines, who knows, so I thought changing table and field collation could be a permanent solution for non-English blogs.

    I now found a solution by goggling it see this post here. I have just tried this at localhost and it worked beautifully.

    Hi,

    i also tried Thomas’s method, all checked and done, but my post (which was formerly typed in both english and chinese in blogger and recently imported into wp)chinese character is still showing “???”.

    Any idea?

    Post in question
    http://www.chanlegacy.com/2006/10/14/placentafor-what/

    I tried the method that Thomas suggested…and got this:

    Fatal error: Call to undefined function: wp() in /home/tental2/public_html/wp-blog-header.php on line 18

    Sigh. Anyone has a suggestion?

    Found out what the problem was – apparently, Notepad my editor mangled everything up. I used Wordpad, made the carriage returns manually and solved that problem.

    Only to get a new one.

    Warning: Invalid argument supplied for foreach() in /home/tental2/public_html/wp-includes/classes.php on line 88.

    Sigh…

    I’m curious – does anyone know WHY the two lines created the original trouble? Can you post or point to a link? Thanks.

    It does work. Thanks to this great finding. Richard

    Just wanna say “Thank you” to thomasw98.
    Your solution worked perfectly for me.
    实在太感谢了!

    Thanks thomasw98, the steps you mentioned work for Japanese text too.

    I can understand the need to change the encoding for the database; however, for my blog I want to post translations of some of my English-language articles in Chinese, so changing the encoding is not an option, as it will mess up the English posts. Any ideas? I would I be better off just setting up an alternative Chinese-language version of my blog, with its own WP installation?

    Wondering if anyone’s found a solution – I have a blog in English but would like to display two pages, one in Chinese and one in Japanese – is it possible? I have the translations.

    I’m using 2.3.3

    I am using 2.5.1

    After modifying the wp-config.php file remoiving those two lines, I have no problem writing a new chinese post.

    But ALL my chinese post imported from a previous backup will not display properly. All appear as question marks

    Any way to solve the problem?

Viewing 12 replies - 31 through 42 (of 42 total)
  • The topic ‘Unicode chinese turn into symbols after upgrade to wp2.2’ is closed to new replies.