Unicode characters replaced by ? on new host (1 post)

  1. DisplacedHoser
    Posted 6 years ago #

    Hello! I just moved my WordPress installation from one host to another (keeping the same domain name); I had followed the usual recommended procedure of backing up the site to my hard drive and then restoring it using phpMyAdmin. At first there was a hitch because my theme (Pixel, formerly called Pixeled when I installed it before) didn't appear to survive the transition. I installed a new version of the theme and it worked fine except for one glitch. I use a lot of Unicode characters with Sanskrit diacritical marks (such as Śāntideva and adṛṣṭa); these worked fine on my old installation, but now they appear as ?s.

    At http://hansengel.wordpress.com/2007/10/09/wordpress-unicode-and-s/ someone recommended using // to comment out the lines containing DB_CHARSET and DB_COLLATE in my wp_config.php file. That did NOT work; it broke things further because even French characters like é (which currently work) stopped working.

    Is it something to do with the theme? Does the new version have a font that doesn't use Unicode characters, or something?

Topic Closed

This topic has been closed to new replies.

About this Topic

  • RSS feed for this topic
  • Started 6 years ago by DisplacedHoser
  • This topic is not resolved
  • WordPress version: 2.9.2