Support » Fixing WordPress » Unicode characters not showing after 2.5.1 upgrade

  • Resolved Nipon


    After I uploaded my blog from 2.3.3 to 2.5.1 I see the unicode (bengali characters) are not showing. instead i see something like an ascii mess. the english posts are of course ok.

    the unicode setting in wp admin is utf – 8 as it always was. same for mysql db collation.

    the unicode characters are not showing not only on the blog but also in the admin interface.

Viewing 4 replies - 1 through 4 (of 4 total)
  • This usually happens when during the upgrade you over-write or change the wp-config.php file. Older versions did not have the charset and collation lines… (anyway it would have been useless for older MySQL versions), so introducing them later = messes up everything.

    Was this an automated upgrade via Fantastico?

    No it was a manual upgrade. But yes, I changed the wp-config.php replacing the old one with the new. This I did to enable the secret key feature.

    These are the lines in my wp-config.php

    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);


    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', 'utf8_unicode_ci');

    @manchumara: that didn’t work for me! Actually defining the charset and collation will work for new installations only.

    Anyways I solved this problem and forgot to update here. What I did was, I deleted the two lines

    define(‘DB_CHARSET’, ”);
    define(‘DB_COLLATE’, ”);

    This is the easy workaround. The other lengthy solution is to convert your database character set. Details here

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Unicode characters not showing after 2.5.1 upgrade’ is closed to new replies.