Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » Unfortunately has never worked properly.

  • I’ve been developing on WordPress since around v2.1 and, simply for the sake of it being incredibly well-known, have often used NextGen for gallery requirements.

    I also develop plugins, usually bespoke ones to meet clients’ precise needs, and I know how easy it is to get carried away with constantly adding new features (“Oh hey, wouldn’t it be great if it did THAT too!”), and then how difficult it can be to maintain a couple of years down the line when WordPress has changed so significantly.

    However, the fact is that I have never found NextGen to not be buggy in some way. Practically every upgrade has brought about issues that we need to go and fix for clients we haven’t dealt with for months. With this last update, a single client has experienced the following problems:

    • Go to Gallery; click on XX Images (admin.php?page=nggallery-add-gallery); “You do not have sufficient permissions to access this page”.
    • Upload an image; appears to upload just fine, except there’s no thumb, no meta (‘January 1, 1970’), and no file when checking in FTP. Permissions checked and rechecked, gallery folder moved, all images deleted and re-uploaded… nothing fixes it.
    • Warning about a stylesheet (nggallery.css) being in the wrong place (i.e. the current theme folder), except that a) NextGen created that file in that location when updated; b) the warning asks me to move it… to the same location it’s already in; and c) that warning appears on every page of wp-admin and there’s no way of turning it off (Note: in the end I moved it via FTP to /wp-content/ngg_styles/ and the message finally disappeared)
    • All of the careful markup and styling that was created to display the client’s gallery has been unceremoniously ignored with the latest update, and so I have to code it all up again. From scratch.

    This has, unfortunately, become the last straw. The client is panicking and I’m left with no recourse but to find an alternative that simply works.

    I’m always reluctant to criticise the efforts of hard-working plugin authors; not least because I know the effort it takes to create a feature-rich plugin, and because this software is available to all of us for free. However, I cannot in good conscience recommend something that I have never had working satisfactorily for more than a few months at a time.

  • The topic ‘Unfortunately has never worked properly.’ is closed to new replies.