• Resolved Prashant

    (@prash18)


    Hi,

    1. Here is my template / format for Payment Received email to be sent to admin.
    But this is the way its sending the mails. What could be wrong?

    Not only this… I think all the email formats have become like this… I checked Payment Received, Invoice available and Estimate Available , all these 3 r like that. I don’t want to reset them to default as I want the layout / formatting changes I made in them.

    2. I want to decrease the size of ‘Payment Pending’ badge or any other badge on the invoice. Its hiding the tasks in the invoice.

    Please, suggest a solution.

    Regards!

    Prashant… 🙂

    • This topic was modified 4 years, 9 months ago by Prashant.
Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter Prashant

    (@prash18)

    Hi,

    showing this on dashboard…
    Warning: printf(): Too few arguments in /home/h7cc1beh25ov/public_html/wp-content/plugins/sprout-invoices/views/admin/dashboards/estimates.php on line 98

    Thread Starter Prashant

    (@prash18)

    Hi,

    I tried resetting the notification mail formats but its still not working…

    Please, help as soon as possible.

    Regards

    Prashant… 🙂

    Thread Starter Prashant

    (@prash18)

    Opting for HTML notifications when HTML plugin is not installed caused the issue. Opted back to plain text and got it solved.

    Plugin Author Dan Cameron

    (@dancameron)

    Glad you figured it out.

    FYI: If you wanted to write your own HTML notifications you could do this and use that setting.

    Thread Starter Prashant

    (@prash18)

    Ohh,
    yes, I chose HTML because I was trying to write my own HTML emails but the code I put there didn’t work. Can you please check, why it didn’t work. Emails sent with the html code showed html email not the formatted email. Is it becuase, I dont have sprout’s HTML add -on?

    Regards

    Prashant… 🙂

    Plugin Author Dan Cameron

    (@dancameron)

    Hello,

    If you wrote your notification templates to use HTML just make sure that you selected the HTML format option within settings.

    Hope that helps.

    Kind Regards,

    Thread Starter Prashant

    (@prash18)

    Hi Dan,
    Thanks for the help. My notifications are looking quite nice with HTML just one thing…
    Shortcode [line_item_plain_list] showing me unformatted output like this…

    What can I do?

    Regards!

    Prashant… 🙂

    Plugin Author Dan Cameron

    (@dancameron)

    Hello,

    You would need to filter that shortcode to create an HTML output.

    The filter is – shortcode_line_item_table

    Here’s a couple filters that can help – https://gist.github.com/search?utf8=✓&q=shortcode_line_item_table

    Kind Regards,

    Thread Starter Prashant

    (@prash18)

    Sorry, I couldn’t get you. Should I make a code snippet for this or this code?

    Plz elaborate a bit , I am not a code tech guy…

    Regards

    Prashant… 🙂

    Thread Starter Prashant

    (@prash18)

    please, reply

    Plugin Author Dan Cameron

    (@dancameron)

    Apologies for the delayed response, we didn’t get a previous notification.

    The second snippet is a great start to make the shortcode use HTML.
    https://gist.github.com/dancameron/e4b47aabe3f460d8b20f

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Unformatted Payment Received Mail’ is closed to new replies.