• Resolved dogstalker

    (@dogstalker)


    WF hangs on all three and according to the dashboards, the last successful scans were in Oct (unfortunately can’t remember what happened then).

    Details:
    -I have three wordpress installations on a shared Lite Speed V6.9 server.

    -The one I’m trying to get WF working on is a multisite.

    -The max_execution_time is 300.

    -PHP is 5.6.19

    -WF installed at the network not site level.

    -Generally no error is seen using debugging mode, except on a couple of occasions when Wordfence “could not find a saved cron key to start the scan so assuming it started and exiting.” The last time I saw this I waited 10 minutes before trying again – no error but still hanging.

    -Tried Maximum execution time at blank, set to 20 and 240.

    -Uninstalled and reinstalled Wordfence.

    -Check boxes for Scan files outside your WordPress installation, Scan images, binary, and other files as if they were executable, Enable HIGH SENSITIVITY scanning (may give false positives) are unchecked.

    -Use low resource scanning (reduces server load by lengthening the scan duration) is checked.

    -The htaccess file in the directory with this WP installation as does the htaccess in my public htlp director both have this code at the top:

    # BEGIN litespeed noabort
    <IfModule rewrite_module>
            RewriteEngine On
            RewriteRule .* - [E=noabort:1]
    </IfModule>
    # END litespeed noabort

    -I tried the other two sets of code recommended for htaccess, but no success.

    -I have W3 Total Cache installed, database cache is disabled.

    -I added the following to both htaccess files under the previous code and ran 10 minutes after a kill request this time. No error this time but appears hangs about 15 seconds later.

    <IfModule mod_security.c>
      SecFilterEngine Off
      SecFilterScanPOST Off
    </IfModule><

    Not sure what else to try. Any recommendations?

    Thanks!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Support wfphil

    (@wfphil)

    Hello,

    Sorry for the delay in replying. You have just about covered everything. One thing that you can try which has been known to help in some instances is to adjust “Maximum execution time for each scan stage” to 15.

    Do you know if there were any server updates carried out at the time that scans stopped running successfully?

    • This reply was modified 4 years, 8 months ago by wfphil.
    • This reply was modified 4 years, 8 months ago by wfphil.
    Thread Starter dogstalker

    (@dogstalker)

    Thanks for the reply. Yes, I have WF installed on the other two websites (they are not multisites), and none are finishing. However, I just had a look on the multisite activity log and saw this error when it automatically started up the scan earlier this morning:

    “Wordfence could not find a saved cron key to start the scan so assuming it started and exiting.”

    Perhaps that sheds some light? I’ve seen it before, but I thought it was because I had been running scans because it wasn’t consistent.

    • This reply was modified 4 years, 8 months ago by dogstalker.
    • This reply was modified 4 years, 8 months ago by dogstalker.
    Plugin Support wfphil

    (@wfphil)

    Hello,

    Thank you for the feedback. Yes, I did ask if you had Wordfence installed on all three sites and if the same problem existed. As your post was so long I didn’t recall that you had said that, so I edited my reply accordingly.

    That type error message you saw is usually related to a database conflict where a plugin has database caching functionality. Disabled database caching in your W3TC plugin seems not to be the cause here. After investigating that specific error message this is what I would like you to do please as a test on one of the sites that is not the Multisite WordPress installation:

    1. On the “Options” page set “Maximum execution time for each scan stage” to 20
    2. On the “Diagnostics” tab on the “Tools” page please enable “Start all scans remotely”
    3. Can I also ask for the test above what version of Wordfence is installed please?

    Plugin Support wfphil

    (@wfphil)

    Hello,

    Thank you for the feedback. Yes, I did ask if you had Wordfence installed on all three sites and if the same problem existed. As your post was so long I didn’t recall that you had said that, so I edited my reply accordingly.

    That type error message you saw is usually related to a database conflict where a plugin has database caching functionality. Disabled database caching in your W3TC plugin seems not to be the cause here. After investigating that specific error message this is what I would like you to do please as a test on one of the sites that is not the Multisite WordPress installation:

    1. On the “Options” page set “Maximum execution time for each scan stage” to 20
    2. On the “Diagnostics” tab on the “Tools” page please enable “Start all scans remotely”

    Can I also ask for the test above what version of Wordfence is installed please?

    Thread Starter dogstalker

    (@dogstalker)

    EDIT: I’m sorry I didn’t see the previous message before I wrote this. Trying your suggestion now.

    I’ve tried adjusting the “Maximum execution time for each scan stage” to 15 (and blank, and 20 and 240). I’ve checked with my host and they don’t think there any server updates around the time it stopped working. I see now that the three sites stopped scanning at different times, I thought they were all around October, but one was in late September. I also forgot to mention that I deactivated the current theme except for 2016 as well as all the plugins besides Wordfence and tested it that. Still getting the errors.
    I’m submitting a ticket to their tech support. If you can think of anything else, please let me know. Thanks!

    • This reply was modified 4 years, 8 months ago by dogstalker.
    Thread Starter dogstalker

    (@dogstalker)

    Thank you. Sorry for the length, I was trying to provide all relevant details.

    I set “Maximum execution time for each scan stage” to 20 and enabled “Start all scans remotely” on a non-multisite, and ran into the same error.

    Wordfence version 6.3.6

    Plugins that are installed and activated plugins on this site are:
    -Contact Form 7
    -Google Analytics for WordPress by MonsterInsights
    -Jetpack
    -NextGEN Gallery

    Plugin Support wfphil

    (@wfphil)

    Hello,

    Please don’t apologise – the more information the better!

    Can you run another scan with the following options on one of the sites that is not the Multisite and then on the “Scan” page click on the “Email activity log” text link and send the log to phil [@] wordfence [dot] com please.

    1. On the “Options” page set “Maximum execution time for each scan stage” to 20
    2. On the “Diagnostics” tab on the “Tools” page please enable “Start all scans remotely”
    3. On the “Diagnostics” tab on the “Tools” page please enable the option “Enable debugging mode”

    Thank you.

    Thread Starter dogstalker

    (@dogstalker)

    Done. Thank you!

    Plugin Support wfphil

    (@wfphil)

    Hello,

    Thanks for sending the logs. There are two .htaccess file rules that we can try. Please try the first one by adding it to your .htaccess file and see if this allows scans to finish. Please add it above the line that says “# BEGIN WordPress”:

    RewriteEngine On
    RewriteRule .* - [E=noconntimeout:1]

    If the above rule doesn’t help and “Mod_Security” is installed on the server this may help. Again, please add it above the line that says “# BEGIN WordPress”:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
    Plugin Support wfphil

    (@wfphil)

    Hello,

    With regards my last post to you I need to update the first rule to:

    <IfModule Litespeed> 
    RewriteEngine On
    RewriteRule .* - [E=noconntimeout:1]
    </IfModule>

    Thank you.

    Thread Starter dogstalker

    (@dogstalker)

    Thanks for this, but no luck. I contacted my host about it, they’re the ones that actually added the both codes to the .htaccess file. They weren’t able to get the scans to finish either. I just emailed you the log again. Not sure if that helps.

    Plugin Support wfphil

    (@wfphil)

    Hello,

    Sorry for the late reply. After asking for assistance from another team member the error message usually means that there’s some sort of caching problem happening that’s holding that session key that gets sent to us.

    Can you also disable browser caching in W3TC, clear your caches and try another scan.

    If that doesn’t help can you clear W3TC caches and disable the entire plugin to see if this helps please.

    Thread Starter dogstalker

    (@dogstalker)

    I tried that, but w3tc was installed on only one site and it had been disabled when I started to try to trouble shoot. What I ended up doing was deleting W3tc plugin as a precation (and purged the cache) and deleted all three of the WF plugins plus the tables & data for all three sites on activation, and started from scratch.

    My multisite has run successfully twice and hung up once when I was in debugging mode (perhaps a server thing), but no error. I will re-introduce W3tc soon. The other two sites also ran successfully. So hopefully, this fixed it and I will mark it as resolved.

    Thank you for replies and responses. Very appreciated. Hopefully my experience will help someone else out. For anyone who runs into this same kind of problem, there is an option on the options page to do this – just make note your settings before you do.

    Thanks again.

    Thread Starter dogstalker

    (@dogstalker)

    I tried that, but w3tc was installed on only one site and it had been disabled when I started to try to trouble shoot. What I ended up doing was deleting W3tc plugin as a precaution (and purged the cache) and deleted all three of the WF plugins plus the tables & data for all three sites on activation, and started from scratch.

    My multisite has run successfully twice and hung up once when I was in debugging mode (perhaps a server thing), but no error. I will re-introduce W3tc soon. The other two sites also ran successfully. So hopefully, this fixed it and I will mark it as resolved.

    Thank you for replies and responses. Very appreciated. Hopefully my experience will help someone else out. For anyone who runs into this same kind of problem, there is an option on the options page to do this – just make note your settings before you do.

    Thanks again.

    Plugin Support wfphil

    (@wfphil)

    Hello,

    Thank you very much for replying with your solution. That is very helpful to us and the rest of the Wordfence community. If other people have similar issues then we have extra advice to give them.

    Whilst in debugging mode Wordfence does consume more server resources and is the most likely cause of the hang. What you can do is enable the scan option “Use low resource scanning (reduces server load by lengthening the scan duration)”. This may help in this instance.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Unfinished scans’ is closed to new replies.