• Resolved wpstack92

    (@wpstack92)


    Hi there,

    On the setup page “/wp-admin/admin.php?page=wc-admin&path=%2Fgoogle%2Fsetup-mc” there comes this error message:

    “Unexpected value in $auth option, got: Automattic\WooCommerce\GoogleListingsAndAds\Vendor\Google\Auth\Credentials\InsecureCredentials Object ( [token:Automattic\WooCommerce\GoogleListingsAndAds\Vendor\Google\Auth\Credentials\InsecureCredentials:private] => Array ( [access_token] => ) ) “

    And the Google Ads section just keeps infinite spinning.

    I tried to add the account id via this page admin.php?page=connection-test-admin-page and same error comes back, even after de-linking and linking again still error:

    ResponseProxied request > get ad campaigns (REDACTEDCUSTOMERIDNUMBER) Error: Unexpected value in $auth option, got: Automattic\WooCommerce\GoogleListingsAndAds\Vendor\Google\Auth\Credentials\InsecureCredentials Object ( [token:Automattic\WooCommerce\GoogleListingsAndAds\Vendor\Google\Auth\Credentials\InsecureCredentials:private] => Array ( [access_token] => ) )

    I can manually link and unlink Google Ads with the Merchant Center directly via google, but this link is also not recognized by the plugin.

    Thank you for your support and tips in fixing this!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support omarfpg (woo-hc)

    (@omarfpg)

    Hi @wpstack92,

    I understand you’re having troubles connecting Google Ads account but are receiving an error, even through the connection test link. This is unusual and it may mean something could be interferring with your set up. I’d like to understand your site properly. Please share with us the necessary information below for us to investigate the issue further:

    • System Status Report which you can find via WooCommerce > Status > Get system report > Copy for support.
    • Fatal error logs (if any) under WooCommerce > Status > Logs.

    You could copy and paste your reply here or paste it via https://gist.github.com/ and send the link here.

    Once we have more information, we’ll be able to assist you further.

    Thanks!
    -OP

    Thread Starter wpstack92

    (@wpstack92)

    Thank you for your quick reply. There were no fatal errors in the Woocommerce Logs.

    Here the System Status Report:

    WordPress Environment
    
    WordPress address (URL): REDACTED
    Site address (URL): REDACTED
    WC Version: 8.3.1
    REST API Version: 8.3.1
    WC Blocks Version:  11.4.9
    Action Scheduler Version:  3.6.4
    Log Directory Writable: 
    WP Version: 6.4.3
    WP Multisite: –
    WP Memory Limit: 752 MB
    WP Debug Mode: –
    WP Cron: –
    Language: en_US
    External object cache:  Server Environment Server Info: Apache/2.4.58 (Debian)
    PHP Version: 8.1.27
    PHP Post Max Size: 400 MB
    PHP Time Limit: 600
    PHP Max Input Vars: 10000
    cURL Version: 7.64.0
    OpenSSL/1.1.1n SUHOSIN Installed: –
    MySQL Version: 10.5.24-MariaDB-1:10.5.24+maria~deb10-log
    Max Upload Size: 400 MB
    Default Timezone is UTC: 
    fsockopen/cURL: 
    SoapClient: 
    DOMDocument: 
    GZip: 
    Multibyte String: 
    Remote Post: 
    Remote Get:  Database WC Database Version: 8.3.1 Security Secure connection (HTTPS): 
    Hide errors from visitors:  Active Plugins (22) Advanced Custom Fields PRO: by WP Engine – 6.2.6.1
    WordPress Bitcoin Payments - Blockonomics: by Blockonomics – 3.7.0
    Breeze: by Cloudways – 2.1.6
    Classic Editor: by WordPress Contributors – 1.6.3
    Classic Widgets: by WordPress Contributors – 0.3
    Click to Chat: by HoliThemes – 3.33
    Cloudflare: by Cloudflare
    Inc. – 4.12.6 FacetWP: by FacetWP
    LLC – 4.2.7 Fast Velocity Minify: by Raul Peixoto – 3.4.1
    Google Listings and Ads: by WooCommerce – 2.6.4
    Perfmatters: by forgemedia – 2.2.6
    Object Cache Pro: by Rhubarb Group – 1.20.2
    SearchWP WooCommerce Integration: by SearchWP – 1.3.11
    SearchWP: by SearchWP – 4.3.13
    Slim SEO: by eLightUp – 3.23.2
    TI WooCommerce Wishlist: by TemplateInvaders – 2.8.0
    Trustpilot-reviews: by Trustpilot – 2.5.925
    Payment Plugins for Stripe WooCommerce: by Payment Plugins
    support@paymentplugins.com – 3.3.59 WooCommerce: by Automattic – 8.3.1 (update to version 8.7.0 is available)
    WP Mail SMTP: by WPForms – 3.5.2
    WP REST Cache: by Acato – 2024.1.3
    wpformation – 1.9.13.2 Dropin Plugins (2) advanced-cache.php: advanced-cache.php
    object-cache.php: Object Cache Pro (Drop-in) Must Use Plugins (1) WP REST Cache - Must-Use Plugin: by Richard Korthuis - Acato – 2021.3.0 Settings API Enabled: –
    Force SSL: –
    Currency: USD ($)
    Currency Position: left
    Thousand Separator:
    Decimal Separator: .
    Number of Decimals: 2
    Taxonomies: Product Types: external (external)
    grouped (grouped)
    simple (simple)
    variable (variable) Connected to WooCommerce.com: 
    Enforce Approved Product Download Directories: –
    HPOS feature screen enabled: –
    HPOS feature enabled: –
    Order datastore: WC_Order_Data_Store_CPT
    HPOS data sync enabled: – Admin Enabled Features: activity-panels
    analytics
    product-block-editor
    coupons
    core-profiler
    customer-effort-score-tracks
    import-products-task
    experimental-fashion-sample-products
    shipping-smart-defaults
    shipping-setting-tour
    homescreen
    marketing
    mobile-app-banner
    navigation
    onboarding
    onboarding-tasks
    product-variation-management
    remote-inbox-notifications
    remote-free-extensions
    payment-gateway-suggestions
    shipping-label-banner
    subscriptions
    store-alerts
    transient-notices
    woo-mobile-welcome
    wc-pay-promotion
    wc-pay-welcome-page Disabled Features: customize-store
    minified-js
    new-product-management-experience
    product-virtual-downloadable
    product-external-affiliate
    settings
    async-product-editor-category-field Daily Cron:  Next scheduled: 2024-03-19 07:55:31 +01:00
    Options: 
    Notes: 15
    Onboarding: completed Action Scheduler Complete: 316
    Oldest: 2024-03-01 21:24:20 +0100
    Newest: 2024-04-01 19:31:40 +0200 Failed: 8
    Oldest: 2023-11-16 09:15:01 +0100
    Newest: 2024-03-16 23:25:01 +0100 Pending: 3
    Oldest: 2024-04-02 19:31:40 +0200
    Newest: 2024-04-02 19:31:40 +0200 Status report information Generated at: 2024-04-01 21:57:10 +02:00
    • This reply was modified 3 months, 1 week ago by wpstack92.
    Plugin Support Shameem (woo-hc)

    (@shameemreza)

    Hi @wpstack92,

    It sounds like authentication issue. You can resolve the issue by completely disconnecting the current connection and setting it up afresh. Here’s how:

    Next, go to Marketing > Google Listings & Ads and set up the connection again.

    Make sure that you create your Google Ads account with the same ID you use to create your Google Merchant ID. More info: https://woo.com/document/google-listings-and-ads/#general-requirements

    Let us know how it goes!

    Thread Starter wpstack92

    (@wpstack92)

    Thanks for getting back to me, Shameem. I did all the steps again, and still getting the same error. The authentication issue is clearly in connection with Google Ads only. All other linkings are working fine.

    Would it be possible for me to add some debug-lines to the part of the plugin code that deals with the Google Ads connection so you get more information what the posts and responses are?

    Thank you!

    Plugin Support anastas10s (woo-hc)

    (@anastas10s)

    👋 hey @wpstack92

    Thank you for reaching back, with further details on this.

    I went ahead with investigating the site’s System Status Report (SSR). Some observations:

    • WooCommerce – 8.3.1 (update to version 8.7.0 is available)
    • Cloudflare: by Cloudflare Inc. – 4.12.6
    • Fast Velocity Minify: by Raul Peixoto – 3.4.1
    • Perfmatters: by forgemedia – 2.2.6
    • Object Cache Pro: by Rhubarb Group – 1.20.2
    • WP REST Cache: by Acato – 2024.1.3 (under must-use plugin list also)

    Moving forward, kindly make sure there’s a backup available first. Then, make sure WooCommerce is updated to the latest version available.

    In order to update the WooCommerce database to the same (8.7.0) version, there is a dedicated button found in the screen at ‘WooCommerce > Status > Tools’.

    Furthermore, to clarify, did you already have a chance to test with the rest of the plugins listed in my message here (caching/security/performance) temporarily deactivated, and see if the issue persists, or otherwise?

    I hope this is helpful! We look forward to your response. In the meantime, please let us know if you have any further questions or concerns.

    • This reply was modified 3 months, 1 week ago by anastas10s (woo-hc). Reason: added WooCommerce database note
    Thread Starter wpstack92

    (@wpstack92)

    Thank you for chiming in as well, Pepe. I tried it one more time and this time it worked!

    Under Google Ads it said
    “Account 0” Connected

    Cannot give you more information why it worked now, but I’m happy it does. Thank you for your help!

    Plugin Support carolm29 (woo-hc)

    (@carolm29)

    Hey, @wpstack92!

    I’m glad it is working now!

    If the issue comes back or you need help with anything else, please let us know so we can assist you further.

    I’ll close this thread now, okay?

    Have a wonderful day!

    duongtuanv

    (@duongtuanv)

    Hi

    I also encountered a similar issue. After reading through everyone’s discussions and trying to delete the related cache plugins, the problem was resolved.

    So, if anyone else has same error, try disconnecting everything, delete cache plugin, and redoing it.

    • This reply was modified 1 month ago by duongtuanv.
Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.