Support » Plugin: FeedWordPress Advanced Filters » unexpected T_PAAMAYIM_NEKUDOTAYIM

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Bas Schuiling

    (@basszje)

    I’m guessing you are using a PHP version lower than 5.3 and that’s unfortunately not supported. If not I would be interested in your configuration 🙂

    I have working your plugin 0.5 on 5.2 PHP version.

    I have modded some subfunctions. Please, send me a email and i will reply to you with a zip.

    Plugin Author Bas Schuiling

    (@basszje)

    That’s cool 🙂 Why don’t you put the zip somewhere and make a link to here so other people can enjoy this? I’m heavily modifying the plugin every release so I won’t officially support it I guess but you are welcome to maintain 🙂

    I´m going to modify 0.6 version. Then you could see that my modifications are very easy. Would you apply php 5.2 compatibility?

    Spoiler: I employ call_user_func and call_user_func_array

    All done.

    The donwload link: http://www.tartasnuria.com/faf.0.6%20php5.2.zip

    You must change only three files and you can see where the modifications are in three report files.

    I haven´t tested this 0.6 modded version yet, so take at your own risk.

    Plugin Author Bas Schuiling

    (@basszje)

    I will look into it to see this week when I got some time on my hands 🙂

    Plugin Author Bas Schuiling

    (@basszje)

    I’ve been doing some testing but it seems like php 5.2 gives already an error during parsing everything.

    I wanted to workaround to check for PHP version and if lower than 5.3 use your workarounds, otherwise do the normal thing.

    I’ll be trying to get around this, but if not then I’m afraid I’m not willing to sacrifice good code for working around a version of PHP nobody should be using anymore anyway.

    I am getting this error on a multisite using PHP 5.3.27. I can install it on the net dashboard, but if I activate it on a site I get:

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /wp-content/plugins/faf/feedwordpress_advanced_filters.php on line 155

    Plugin Author Bas Schuiling

    (@basszje)

    That’s strange since this is a specific PHP 5.2 problem not of 5.3 onward. Are you sure you are loading the right modules into apache?

    This is on reliable shared hosting I have used for about 8 years. However, of the 35 or so plugins I have installed, more than half seem to require 5.3 and don’t have any problem.

    I am happy to facilitate the investigation of this. What modules does Apache need for FeedWordPress Advanced Filters to work? I’ll ask my host if they are getting loaded.

    Thanks!

    Plugin Author Bas Schuiling

    (@basszje)

    Well Faf needs nothing except for FeedWordPress and PHP 5.3. The whole reason for this error is that the features I’m using don’t exist in PHP 5.2 but DOES in PHP 5.3 .

    Unless for some reason your host doesn’t accept late static bindings , but I don’t think you can even turn that off in PHP 5.3.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘unexpected T_PAAMAYIM_NEKUDOTAYIM’ is closed to new replies.