Support » Plugin: Online Backup for WordPress » Unexpected Stop error

  • Hello,
    The backup was working fine on a nightly basis, then, for the past week, I repeatedly get “Unexpected Stop” errors. When I try and run manually or download a backup, it still doesn’t work. Looking at the event log doesn’t seem to tell me anything (Starting, initializing, etc, but no error info).

    What can I do?

    Info on my setup:
    Online Backup for WordPress Plugin Version 2.2.13
    PHP Version: 5.2.17
    MySQL Server Version: 5.0.92-log
    MySQL Client Version: 1.0
    Mem: 256M; Post: 8M; Upload: 8M; Timeout: 30
    End of Information

Viewing 9 replies - 1 through 9 (of 9 total)
  • When I run it manually, I get this error:

    “A timeout occurred during backup (large files and slow servers are common cause of this) trying again…”

    However, this error happens pretty quickly, as if the “timeout” is very brief. Is there a way to extend this timeout?

    It seems to hang after this message. How long should the backup take?


    I finally got a manual backup to work. The file size is 60.6MB. It took 3 times to try and download it (I kept getting a “network error” at 51.2 MB each time).

    Hopefully, the scheduled backups will start working as expected, but I’m not hopeful.

    Plugin Author Online Backup



    Not sure what caused the timeout. It may have been memory. At what point in the backup does it happen? When the message appears try click event log to see the latest event. I can see it might happen due to memory but seems unlikely for you since you have 256M according to the support info (Mem bit)

    If issue keeps happening we can try a newer version (we’re releasing it very soon but I can give you it early if needed). Latest has some improvements to memory.

    Reason why the message about timeout can appear straight away is some new feature we added some time ago where it can recover instantly from a timeout, error or memory exhaustion and try again. But we didn’t change the error message 🙂 we’ll be making it more detailed and accurate soon.

    For the downloading, for large files on slow connections, because we use PHP to download the file it can abruptly abort the download if it takes too long. We’re adding some feature soon so you can download via FTP if required and to make download via PHP (web browser) a bit more reliable but allowing FTP if needed. At moment we can only download with PHP.

    Hope this answers your concerns!


    Plugin Author Online Backup


    Hi neoikon,

    Please upgrade to latest version of our plugin, 2.2.15 and let us know if issue continues.

    As mentioned above, if issue continues can you tell us at what point in backup it gets unexpected stop? Best thing to do is actually click Events when it fails and then copy and paste the entire event log in a reply, but make sure to click “b-quote” before pasting it in and then click “/b-quote” so it puts the log in blockquotes and makes it easier to read.




    Thank you for your reply. I just installed the latest version (x.15, up from my old version x.13).

    I tried a manual backup (online type) and it failed with this message:
    “The backup failed: Communication with the online backup vault failed; more information can be found in the Activity Log. Please consult the event log for more information.”

    I checked the log, which had some additional information:
    “A transmission operation failed.
    If the following error message is not clear as to the problem and the issue persists, please contact support providing the complete event log for the activity. Diagnostic information follows:

    Failed at: D:\Hosting\<my_path>\plugins\wponlinebackup\include\transmission.php(920)
    A request failed for API Status.
    Please ensure your blog is able to perform HTTPS requests to You may need to contact your web host regarding this.
    [Error Code http_request_failed] SSL certificate problem, verify that the CA cert is OK. Details:
    error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed”

    I’m not sure how to check/modify my access to that HTTPS link.

    When I go to the “Online Backup Settings” tab, everything seems to be okay (saying it’s connected and available).

    I was able to do a manual backup (download type). The backup itself is successful. However, I repeatedly get “Network Errors” mid-way during the actual download. Where is this backup (ZIP file) on my server? Perhaps I can just FTP it down from the web server itself?


    I found the backup location on my web server, but it seems to be encrypted (as expected). Is there a manual way of decrypting it (not through the plugin interface)? (I have my password)


    I’ve tried to download the file through the plugin interface about 6+ times now and it keeps failing (“network error”). I’m sure it’s some kind of script timeout that haults the download.

    Plugin Author Online Backup


    Hi neoikon,

    We don’t have the ability to FTP transfer the file yet. But we’re working on adding it.

    The certificate problem will be the fault of your web host. The CA certificate list is probably out of date and doesn’t have the latest ones. That might mean our certificate is too recent for the web host. If the host updates their ca-bundle.crt it will fix the issue. But we tend to experience resistance from hosts in doing that. There is a hidden setting to disable the security but that is not ideal and it’s best to try contact the web host to update their security.


    At the moment, I’d just be happy being able to download my manual backup. My backup is currently 66 MB. When I “download full backup”, it gets to about 51.2 MB, then stops, which times out with a “network error” (in Chrome).

    I tried in Firefox as well and it stops at the same spot too.

    My only thought is that the PHP script that is allowing the download is decrypting the file while it is downloading, but the script itself is being timed out by the web server after 90 seconds? 2 minutes?

    SO, I added this to my /wordpress level web.config:
    <httpRuntime executionTimeout=”300″ /><!– seconds –>

    BUT, still no dice. Still stops at 51.2MB (almost there!)

    Is there something that you can think of that would be going on with the manual download?

    (thanks for the help!)

    Plugin Author Online Backup


    Hi neoikon,

    Tends to be the timeout as you say, but it’s not decrypting the backup as it downloads, it just streams the data to you in ZIP format.

    Most servers it works fine but some it doesn’t let the script adjust the timeout and so it stops in middle.

    Might need to wait for our next update where you’ll be able to browse to that tmp/full folder and download it via FTP as the file in there will be a ZIP file also.


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Unexpected Stop error’ is closed to new replies.