Support » Plugin: AMP for WP - Accelerated Mobile Pages » Undefined varible and Warning Messages

  • Resolved elward

    (@elward)



    The following errors show on admin backend constantly. I have seen a similar error on the frontend with slow mobile internet connection. Have WP Version 4.9.8 and plugin AMP Version 0.9.97.18.

    Undefined variable: tags_array in /home/cynerg7/itriumph.org/wp-content/plugins/accelerated-mobile-pages/includes/options/admin-config.php on line 5303

    Warning: session_start(): Cannot send session cache limiter – headers already sent (output started at /home/cynerg7/itriumph.org/wp-content/plugins/accelerated-mobile-pages/includes/options/admin-config.php:5303) in /home/cynerg7/itriumph.org/wp-content/plugins/userpro/index.php on line 34

    When Userpro plugin is deactived only the “Undefined variable” message remains.

    These messages appeared about two (AMP) updates ago. Any thoughts would be appreciated.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Mohammed Kaleem

    (@beingsmart)

    Hi @elward

    Thank you for letting us know and to fix this warning immediately

    Go to WP-config.php file in that you’ll see this code define(‘WP_DEBUG’, true);
    just make it false to wp-debug like this define(‘WP_DEBUG’, false); and clear the cache and check your PHP warning issue gets fixed.

    Hi there, have the first warning as well – not displaying it doesn’t fix it, does it :)?

    Hi @physalis,

    Yes, you are right, we solve them whenever we see them, but sometimes it can take some time that’s why we ask them to turn off the debug mode.

    Can you share what warning you are seeing? so that I can check and resolve it?

    physalis

    (@physalis)

    Hi @marqas,

    thanks for getting back. Yeah, I get it, it just sounded so simply put to disable debug mode 😉 .

    However, this is the message your plugin generates:

    Notice: Undefined variable: tags_array in /this/is/my/path/wp-content/plugins/accelerated-mobile-pages/includes/options/admin-config.php on line 5400

    It though only appears in the backend, fingers crossed :)!

    Marqas

    (@marqas)

    Hi @physalis,

    I have created a Github ticket for this and resolved it, it will be added in out future updates.
    ref: https://github.com/ahmedkaludi/accelerated-mobile-pages/issues/2627

    If you want you can look into the code changes and make the same changes or contact our team at team@magazine3.com and our team will help you with it.

    Jedi82

    (@jedi82)

    Me too have this type of error. For what I had understand, we must wait for an update right ?

    Notice: Undefined variable: tags_array in /home/…/public_html/wp-content/plugins/accelerated-mobile-pages/includes/options/admin-config.php on line 5400

    Hi @jedi82,

    We have resolved this issue and it will be added in our next updates.
    Please be patient with us.

    Of course I will 😉

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.