WordPress.org

Support

Support » Plugins and Hacks » iiRe Social Icons » [Resolved] "undefined" instead of icons after modification

[Resolved] "undefined" instead of icons after modification

  • Every time I modify something on the shortcode designer, I will have the phrase “undefined” on the wordpress-site instead of the icons.
    My workaround is to reset and reconfigure all settings/icons each time. But it would be handy if a modification of icons is possible without reconfiguring all. (behaviour even with the full version)

    http://wordpress.org/extend/plugins/iire-social-icons/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author srussell13

    @srussell13

    You should not have to reset each time a modification. It sounds like the settings are not being saved

    Can you send a link to your site where you are using the plugin?

    The site is not ready yet but you may find it here: http://staging.ubiquarian.net

    ..of course, after happening yesterday inadvertently at least 10 times and always by the same way, I can currently not reproduce it.

    But maybe you can use the link for the other issue as well.

    Plugin Author srussell13

    @srussell13

    Can’t debug from my end, but possibly because it’s on a staging server? The plugin javascript (or Jquery) may not be loading.

    You might also try a reset, adding your icons, save settings, then make the appropriate edits.

    It was the same on the live server, but currently you can’t load the starting page there.
    Maybe there was some performance-issue with my host.

    Anyway, as I can’t reproduce it any more I’ll put this on resolved.
    Thanks.

    I’m sorry, it just happened again, see here: undefined

    This is the source code but I’m afraid this wont help:

    <div class="iire_social_shortcode" id="iire_social_shortcode">
    <a class="iire-facebook" rel="nofollow" target="_blank" href="http://facebook.com">undefined</a>
    <a class="iire-googleplus" rel="nofollow" target="_blank" href="https://plus.google.com/u/0/110362418117155780512/posts">undefined</a>
    <a class="iire-twitter" rel="nofollow" target="_blank" href="http://twitter.com">undefined</a><
    a class="iire-rss" rel="nofollow" target="_blank" href="http://staging.ubiquarian.net/feed.rss">undefined</a>
    undefinedundefined</div>

    Lucky I made an export of the table wp_iire_social right before this happened, so I could compare the differences, just some settings (I can send you the tables if you want). I restored the previous values but it still shows undefined.

    Anything else I can do? I’ll try to keep it ‘undefined’ until you may check it.

    Plugin Author srussell13

    @srussell13

    I just sent you a link with a correction for the More Info and a previous email for some other things you can try.

    Plugin Author srussell13

    @srussell13

    If anyone else has been able to reproduce this error, please send me an email srussell at iireproduction dot com with the WordPress setup, theme and other plugins you are using. So far, I have been unable to replicate the problem on many different installations.

    Plugin Author srussell13

    @srussell13

    This issue had been resolved in the latest release.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] "undefined" instead of icons after modification’ is closed to new replies.
Skip to toolbar