Support » Plugin: WPComplete » Undefined index on post/page publish

  • Resolved pasada

    (@pasadamedia)


    Installed plugin on fresh WP install with no other plugins loaded and default theme. Throws the following error when post or page is published, with or without “Enable Complete button” checked:

    Notice: Undefined index: course in /PATH-REDACTED/wp-content/plugins/wpcomplete/admin/class-wpcomplete-admin.php on line 821
    
    Notice: Undefined index: completion-redirect-to in /PATH-REDACTED/wp-content/plugins/wpcomplete/admin/class-wpcomplete-admin.php on line 823
    
    Notice: Undefined index: completion-redirect-url in /PATH-REDACTED/wp-content/plugins/wpcomplete/admin/class-wpcomplete-admin.php on line 824
    
    Warning: Cannot modify header information - headers already sent by (output started at /PATH-REDACTED/wp-content/plugins/wpcomplete/admin/class-wpcomplete-admin.php:821) in /srv/users/serverpilot/apps/dev/public/wp-admin/post.php on line 197
    
    Warning: Cannot modify header information - headers already sent by (output started at /PATH-REDACTED/wp-content/plugins/wpcomplete/admin/class-wpcomplete-admin.php:821) in /srv/users/serverpilot/apps/dev/public/wp-includes/pluggable.php on line 1210
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author zackgilbert

    (@zackgilbert)

    @pasadamedia Hey Greg.

    First off, my apologies for taking so long to get back to you about this. When I tried to checkout the issue before, it had disappeared, so I thought you had deleted it.

    Now to business: Are you using the free or paid version of the plugin? If it’s the paid, do you know what version of the plugin you have installed? I’m not seeing those line numbers line up, so I’m thinking this is a resolved issue.

    Also, for the fastest support, please email us: nerds@wpcomplete.co

    Plugin Author zackgilbert

    (@zackgilbert)

    This appears to be an issue with the free plugin, but we haven’t been able to reproduce it ourselves. My guess is that it’s an issue with an older version of PHP or WordPress. Please make sure you have a version of PHP that is newer than 5.3, as that version has had known issues. We will keep trying to troubleshoot and will report back for others.

    pasada

    (@pasadamedia)

    Tested with both PHP 7.1 and 5.6.

    Plugin Author zackgilbert

    (@zackgilbert)

    Hey Greg (@pasadamedia)!

    We just released a new version of the free plugin (1.4.6) that should fix this issue. Please update it and let us know if you continue to have problems.

    We will roll out these updates to the Pro (paid) version shortly (along with some other really cool updates)!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Undefined index on post/page publish’ is closed to new replies.