WordPress.org

Support

Support » Plugins and Hacks » Google+ Crossposting » [Resolved] Undefined Index Notice

[Resolved] Undefined Index Notice

  • I’m getting a frequent notice in my debug.log based on the manual import functionality of G+ Crossposting.

    PHP Notice: Undefined index: g_crossposting_manual_import in /home/content/70/7126070/html/wordpress/wp-content/plugins/g-crossposting/admin.php on line 24

    That correlates to this line in admin.php.
    if ($_GET['g_crossposting_manual_import']) {

    I’m not sure what the issue is, unless it is getting a null response to the function. I have never used the manual import function, but it is showing quite frequently in my log.

    http://wordpress.org/extend/plugins/g-crossposting/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Sebastian

    @sebstein

    Mmmh, not good to hear that my plugin is spamming your log files. But at least I can assure you that it is not a big problem. But of course I should use a better function to test whether the environment contains the manual import flag.

    I just submitted a fix. It would be great if you can test it before I make the official 1.1.3 release.

    Can you please replace in admin.php line 24 with:

    if (array_key_exists('g_crossposting_manual_import', $_GET)) {

    You can view the complete file at:

    http://plugins.svn.wordpress.org/g-crossposting/trunk/admin.php

    Sebastian,

    I appreciate the quick feedback, that seems to have resolved it, however I’ve found another notice now that was also there all of the time:

    PHP Notice: Undefined property: stdClass::$error in /home/content/70/7126070/html/wordpress/wp-content/plugins/g-crossposting/gplus-crosspost.php on line 228

    Sorry I missed that one earlier.

    I’m very happy with this plugin, it has allowed us to multiply our distribution channels without extra work.

    Thanks,

    mgs

    Plugin Author Sebastian

    @sebstein

    Ok, but this one should only happen if G+ API returns not a single post. Anyway, I fixed it and the new version 1.1.3 should be on it’s way now!

    Interesting. I have numerous posts that have been pulled in, yet I was getting up to 2 per second and at least every 21 minutes over the last day.

    I installed the update and they seem to have gone away. I really appreciate the help, and I like your idea for donations!

    Plugin Author Sebastian

    @sebstein

    Hi mgs00,

    so everything is fine or are you experiencing problems with the latest update?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Undefined Index Notice’ is closed to new replies.
Skip to toolbar