WordPress.org

Forums

Manual Image Crop
[resolved] Undefined index ManualImageCropEditorWindow.php on line 49 (11 posts)

  1. kkielexed
    Member
    Posted 11 months ago #

    First off all beautiful plugin.

    But when I true to crop an image I receive the following message:
    Notice: Undefined index: large in /plugins/manual-image-crop/lib/ManualImageCropEditorWindow.php on line 49

    Can you resolve this in your next update?

    https://wordpress.org/plugins/manual-image-crop/

  2. sbornia
    Member
    Posted 11 months ago #

    Same issue here. And the plugin stopped working also: when I click the Crop it button nothing happens anymore.

    Here's a screenshot of the error messages: https://www.dropbox.com/s/riye99zrs8dq6sl/Screenshot%202014-08-18%2015.17.14.png

    Thanks!

  3. Tomasz Sita
    Member
    Plugin Author

    Posted 11 months ago #

    Can you try to go to the plugin's settings page and re-save the settings?

  4. sbornia
    Member
    Posted 11 months ago #

    Hi!

    Thanks for the response :)

    I did what you asked and many of the error messages disappeared, but unfortunately two of them still remain (screenshot). The two error messages are for image sizes that I didn't set (medium and large), I'm not so sure where those image sizes are coming from?

    Also the plugin still doesn't work. When I click the Crop It button nothing happens.

    Thanks again for your response!

    Regards,
    Sebastian

  5. kkielexed
    Member
    Posted 11 months ago #

    @Tomasz Sita can you build in a check if the index is set? I think that fix the problem :)

  6. sebabornia
    Member
    Posted 10 months ago #

    Hey... any updates on this? Thanks!

  7. Florian Girardey
    Member
    Posted 10 months ago #

    Re-up

    I got the same problem even if i update the plugin settings.

  8. Tomasz Sita
    Member
    Plugin Author

    Posted 10 months ago #

    Hi,

    the fix is on the way:)

  9. Florian Girardey
    Member
    Posted 9 months ago #

    Hi Tomasz,

    Still on the way ? O:)

  10. jamesckemp
    Member
    Posted 9 months ago #

    Hi Tomasz,

    We had this issue too (please note: it only occurs when error reporting is enabled, if you set wp_debug to log only, the issue goes (or becomes invisible)).

    It's a simple fix though, it just needs 3 isset() statements adding to:

    lib/ManualImageCrop.php

    242: if(isset($_POST['make2x']) && $_POST['make2x'] === 'true') {
    272: if(isset($_POST['make2x']) && $_POST['make2x']...

    lib/ManualImageCropEditorWindow.php

    48: if (!  isset($sizesSettings[$s]) ) {

    This should prevent all errors. The ajax after cropping returns an error, so although cropping still works, it never says complete because the error is being returned insead of the JSON.

  11. Tomasz Sita
    Member
    Plugin Author

    Posted 9 months ago #

    fixed in 1.08

Reply

You must log in to post.

About this Plugin

  • Manual Image Crop
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic