WordPress.org

Forums

Hyper Cache
[resolved] Undefined index in few lines (3 posts)

  1. phoros
    Member
    Posted 1 year ago #

    Hi!

    I'm playing with the plugin and it seems to work pretty well.

    But in options screen the "options.php" file generates PHP "Undefined index..." error in following lines:

    Undefined index: mobile_agents		/hyper-cache/options.php:58
    Undefined index: gzip_on_the_fly	/hyper-cache/options.php:349
    Undefined index: notranslation		/hyper-cache/options.php:370
    Undefined index: lastmodified	 	/hyper-cache/options.php:380
    Undefined index: home			/hyper-cache/options.php:390
    Undefined index: strip_qs		/hyper-cache/options.php:417
    Undefined index: cache_qs		/hyper-cache/options.php:433
    Undefined index: nocache		/hyper-cache/options.php:448
    Undefined index: reject			/hyper-cache/options.php:467
    Undefined index: reject_agents		/hyper-cache/options.php:493
    Undefined index: reject_cookies		/hyper-cache/options.php:504

    I've used isset() function in these places and it solved the problem.
    So, instead of
    $options['mobile_agents']
    I've got
    isset($options['mobile_agents'])etc.
    Hope it could be helpful for someone.
    Cheers!

    https://wordpress.org/plugins/hyper-cache/

  2. mbrsolution
    Member
    Posted 11 months ago #

    Hi phoros you might want to share your solution in the official support forum.

    Kind regards

  3. Stefano Lissa
    Member
    Plugin Author

    Posted 11 months ago #

    Hi, just save the options of the plugin: the options stored should always be present, did you updated the plugin without deactivating it before and the reactivating it?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Hyper Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic