Support » Plugin: Easy WP SMTP » Undefined index in easy-wp-smtp.php

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    Have you set up the plugin correctly? Did you carry out a Test Email test?

    Regards

    Everything is working, this is just a bug report for “View log” functionality. Make sure you have WP_DEBUG_DISPLAY set to true.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    Everything is working, this is just a bug report for “View log” functionality. Make sure you have WP_DEBUG_DISPLAY set to true.

    Can you elaborate further to the following comment Make sure you have WP_DEBUG_DISPLAY set to true.?

    Thank you

    Hello,

    how to reproduce:

    1) enable PHP error output. Every developer knows how to to this, for example, place this into wp-config.php:

    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, true);

    2) go to WP backend -> Settings -> Easy WP SMTP -> Additional Settings -> View log

    3) you will see
    <b>Notice</b>: Undefined index: log_file_name in <b>www/wp-content/plugins/easy-wp-smtp/easy-wp-smtp.php</b> on line <b>260</b><br />
    at the start of the page

    If you don’t see it, then try it with fresh installed plugin.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, is your report the same as the one posted here?

    Regards

    These are 2 separate issues, not related to each other.


    OT: are you able to edit messages in the forum (as a moderator)?

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    OT: are you able to edit messages in the forum (as a moderator)?

    No. Only WordPress staff can.

    Thank you

    • This reply was modified 3 months, 1 week ago by mbrsolution.

    #modlook

    to mods: see original post – please remove everything before wp-content/ from path in the error message. Thanks.

    Plugin Author wp.insider

    (@wpinsider-1)

    I have the following options enabled in my wp-config file but I can’t reproduce this.

    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, true);

    Are you using the latest version of this plugin just to be sure?

    Also, can you hit save settings just to make sure it saves the log file name one time in your install. Then see if the issue is still there after that?

    Improved how-to / try this instead:

    1) set WP_DEBUG, WP_DEBUG_LOG, WP_DEBUG_DISPLAY to true

    2) self destruct

    3) enable plugin

    4) go to WP backend -> Settings -> Easy WP SMTP -> Additional Settings -> View log

    5) you will see
    <b>Notice</b>: Undefined index: log_file_name in <b>www/wp-content/plugins/easy-wp-smtp/easy-wp-smtp.php</b> on line <b>260</b><br />
    at the start of the page

    I can see the message even after checking “Enable Debug Log” to true, saving SMTP settings and sending test message.
    The error disappears after sending first message via php mail() function (any contact form plugin uses it).

    Now I think this error is minor, however you can fix it anyway 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.