Support » Fixing WordPress » Undefined index: HTTP Referer

  • I get the following message displayed at the top of my home page. I can’t get rid of it even when I copy over a ‘clean’ wp-blog-header.php file. Originally, I had transferred my http://www.olympicworksource.com site from one ISP account to another with the same ISP. Everything seems to work fine except this pops up:

    Notice: Undefined index: HTTP_REFERER in /usr/local/pem/vhosts/150175/webspace/httpdocs/wordpress/wp-blog-header.php(359) : eval()’d code on line 485

    Any ideas to fix this are very welcome. Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Howdy,

    What theme are you using?
    wp-blog-header.php is loading some stuff from your theme and maybe plugins, which are most likely the cause of your problem.

    HTTP_REFERER is probably being asked for by a plugin / theme function that is for:
    a. analytics
    b. customizing welcome messages

    Let me know the theme you’re using.
    Also, try turning off all your plugins and then re-enabling them one by one until you see the problem return.

    Take care,
    Paul

    Hi Paul,
    Thanks for responding! I’m using the Twenty Eleven 1.4 theme. I’ve disabled the 2 plugins I have – Akismet and Customer Headers and Footers and then reactivated them one by one with no change to the home page’s error message. Appreciate the help!
    – Bob

    Hey, I figured it out. Thanks to your tip about analytics, I went back to my Google Analytics account and deleted it for that site. I also deleted the code snippet on the wp-blog header file (that’s one long piece of incomprehensible code!). All works again. I just don’t have analytics now which is no big deal. Thanks Paul!

    Glad you figured it out.
    You could also install the Google Analyticator or other such plugin, then just paste in your “UA-whatever’ code for that domain to get back your Analytics if you want.

    Cheers,
    Paul

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Undefined index: HTTP Referer’ is closed to new replies.