Support » Plugin: Addons & Templates for Elementor by Sizzify Lite » “undefined” error on Newsletter form

  • Resolved leanebra

    (@leanebra)


    Hello! I really need help right now. I tried the plugin and I loved it until I add the Newsletter form to link it to my mailchimp. My API key is right (checked a million time, tried with another API key…) and my LIST ID is right too. But when I try to put an email there is the “undefined” error. How can I do? I tried everything 🙁
    Thanks a lot !

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 26 total)
  • experiencebellavita

    (@experiencebellavita)

    I had the same exact problem

    Plugin Support AC

    (@purplecodes)

    Themeisle Support

    Hi there,

    May we have the link to the page where the Newsletter is setup?
    I checked http://leanebra.fr/mon-cadeau-gratuit/ but it can’t be found.

    I’m having this exact same problem. It’s on the homepage at the very bottom:

    Plugin Support Madalin

    (@madalin_themeisle)

    Hey there,

    Sorry for my delayed reply. Could you please confirm us if this issue still persist?

    Yes. But you can’t see it on the site because I don’t publish it since it’s not working. I just added it again so that you could see it still doesn’t work.

    Plugin Support Madalin

    (@madalin_themeisle)

    Hi @sandeld,

    Unfortunately, I could not replicate the issue on my machine. We need to see it live in order to see what’s wrong, or if not, will be great if you can give us more details, as what theme do you use by default, and a screencast while you reproduce the issue.

    In the meantime, please make sure that the Access Key and List ID are correct.

    I made a test page for you to use. Also, any chance that “group” capability is coming, or at least the possibility of adding custom code to a submit event?

    Plugin Support AC

    (@purplecodes)

    Themeisle Support

    Thanks for the link @sandeld.

    Tested it on my end and was able to replicate the issue.

    I have already forwarded the issue to our developers for a fix.

    Hopefully, this will be included on the next update.

    Let us know if we can help you with anything else.

    Why is this marked as resolved? It is still very much broken and unusable.

    Plugin Support Madalin

    (@madalin_themeisle)

    Hey there,

    That issue will be fixed in the upcoming update. If you have any other issue, please open a new thread.

    Thank you for your patience and understanding.

    This post is more of a reminder to myself and for record keeping. The version this is not working on is 1.2.9, last updated on 12/12/2018.

    Which, 2 months without an update with a known, major bug seems very negligent.

    • This reply was modified 1 year, 8 months ago by sandeld.

    I have the same problem and this topic should not be marked as resolved.
    See bottom of https://www.bodycurious.com/
    Can you please let us know how to fix this ?

    hello,

    I experience the same problem as upon.

    Once I click submit, the newsletter form responses with an error “action failed” but i receive a subscription confirmation.

    I integrated with mailchimp.

    Furthermore the only data keept by mailchimp is the email also if in the module there are others fields
    I attached the error.

    `Object
    component: “Plugin: elementor-addon-widgets”
    file: “wp-content/plugins/elementor-addon-widgets/vendor/codeinwp/themeisle-content-forms/class-themeisle-content-forms-newsletter.php”
    line: 173
    message: “Trying to get property of non-object”
    stack: Array(11)
    0: “ThemeIsle\C\NewsletterForm->_subscribe_mail()”
    1: “ThemeIsle\C\NewsletterForm->rest_submit_form()”
    2: “apply_filters(‘content_forms_submit_newsletter’)”
    3: “ThemeIsle\C\RestServer->submit_form()”
    4: “WP_REST_Server->dispatch()”
    5: “WP_REST_Server->serve_request()”
    6: “rest_api_loaded()”
    7: “do_action_ref_array(‘parse_request’)”
    8: “WP->parse_request()”
    9: “WP->main()”
    10: “wp()”
    length: 11
    __proto__: Array(0)
    concat: ƒ concat()
    constructor: ƒ Array()
    copyWithin: ƒ copyWithin()
    entries: ƒ entries()
    every: ƒ every()
    fill: ƒ fill()
    filter: ƒ filter()
    find: ƒ find()
    findIndex: ƒ findIndex()
    flat: ƒ flat()
    flatMap: ƒ flatMap()
    forEach: ƒ forEach()
    includes: ƒ includes()
    indexOf: ƒ indexOf()
    join: ƒ join()
    keys: ƒ keys()
    lastIndexOf: ƒ lastIndexOf()
    length: 0
    map: ƒ map()
    pop: ƒ pop()
    push: ƒ push()
    reduce: ƒ reduce()
    reduceRight: ƒ reduceRight()
    reverse: ƒ reverse()
    shift: ƒ shift()
    slice: ƒ slice()
    some: ƒ some()
    sort: ƒ sort()
    splice: ƒ splice()
    toLocaleString: ƒ toLocaleString()
    toString: ƒ toString()
    unshift: ƒ unshift()
    values: ƒ values()
    Symbol(Symbol.iterator): ƒ values()
    Symbol(Symbol.unscopables): {copyWithin: true, entries: true, fill: true, find: true, findIndex: true, …}
    __proto__: Object
    type: “notice”
    __proto__:
    constructor: ƒ Object()
    hasOwnProperty: ƒ hasOwnProperty()
    isPrototypeOf: ƒ isPrototypeOf()
    propertyIsEnumerable: ƒ propertyIsEnumerable()
    toLocaleString: ƒ toLocaleString()
    toString: ƒ toString()
    valueOf: ƒ valueOf()
    __defineGetter__: ƒ __defineGetter__()
    __defineSetter__: ƒ __defineSetter__()
    __lookupGetter__: ƒ __lookupGetter__()
    __lookupSetter__: ƒ __lookupSetter__()
    get __proto__: ƒ __proto__()
    set __proto__: ƒ __proto__()

    My website is “https://nxtbite.com”.I am using newsletter form of SIZZIFY WIDGETS of elementor addon. I am using access API key and list ID of Mailchimp. This newsletter is available on top the right side of the home page of my website.

    When I input an email, it says “undefined”.I am using WordPress
    Version———5.1.1
    PHP Version: 7.0.33
    Max Upload Size–256 MB
    Theme oceanWP—-1.6.4
    Any solution

    For a topic that is “Resolved” it sure has been broken for over 6 months now. Great support! And yet, they had the audacity to ask me to change my review of the plugin. Hahahahaha! I would give it negative stars if I could. That’s the only way I’m changing it from the current 1-star.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘“undefined” error on Newsletter form’ is closed to new replies.