• WP 5.0.2, PHP 7.2:

    Warning: Use of undefined constant WP_INSTALLER_VERSION – assumed ‘WP_INSTALLER_VERSION’ (this will throw an Error in a future version of PHP) in /srv/bindings/26866470c78246afb0e91a9815b50979/code/wp-content/plugins/types/vendor/otgs/installer/includes/class-otgs-installer-wp-components-setting-resources.php on line 24

    Warning: Use of undefined constant WP_INSTALLER_VERSION – assumed ‘WP_INSTALLER_VERSION’ (this will throw an Error in a future version of PHP) in /srv/bindings/26866470c78246afb0e91a9815b50979/code/wp-content/plugins/types/vendor/otgs/installer/includes/class-otgs-installer-wp-components-setting-resources.php on line 28

    Warning: Use of undefined constant WP_INSTALLER_VERSION – assumed ‘WP_INSTALLER_VERSION’ (this will throw an Error in a future version of PHP) in /srv/bindings/26866470c78246afb0e91a9815b50979/code/wp-content/plugins/types/vendor/otgs/installer/includes/class-otgs-installer-wp-components-setting-resources.php on line 31

    Warning: Use of undefined constant WP_INSTALLER_VERSION – assumed ‘WP_INSTALLER_VERSION’ (this will throw an Error in a future version of PHP) in /srv/bindings/26866470c78246afb0e91a9815b50979/code/wp-content/plugins/types/vendor/otgs/installer/includes/class-otgs-installer-wp-components-setting-resources.php on line 35

    Warning: Use of undefined constant WP_INSTALLER_VERSION – assumed ‘WP_INSTALLER_VERSION’ (this will throw an Error in a future version of PHP) in /srv/bindings/26866470c78246afb0e91a9815b50979/code/wp-content/plugins/types/vendor/otgs/installer/includes/class-otgs-installer-wp-components-setting-resources.php on line 40

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Beda

    (@bedas)

    These are warnings about future versions of PHP, which Types as the free plugin will not support.

    Types will be removed from the repositories here in a few days, as seen here and here.

    I will get a quick confirmation from the developer of Types today about this, however, I fear we cannot adjust problems that eventually will come with future PHP versions, since Types reached it’s “end of life”, in the Free version.

    Plugin Support Beda

    (@bedas)

    I am sorry, I spoke too soon.

    I cannot be that you experience this error, according to what we tested and saw now in the code since the issue could happen only if you are below 1.8.12 version of the installer, which is outdated.

    Are you sure you have updated Toolset Types Free version to it’s the latest version?
    There are no such errors on the PHP 7.x, WordPress 5.x, Types {latest} version

    I also tested this against WP 4.0 just in case.

    Please let me know.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Undefined constant error’ is closed to new replies.