Support » Plugin: Variation Swatches for WooCommerce » Undefined attribute name

  • Resolved bobmorain

    (@bobmorain)


    Hi,

    With version 1.1.0 the “Add: Selected attribute name beside label” feature was added. However, when an attribute is selected “undefined” is displayed instead of the attribute name. The issue persist for all variation products.

    Any suggestion on a solution?

    Thank you,
    Rob

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi @bobmorain

    Please check that you are using the same version (1.1.0) for its advanced plugin.

    Thanks

    Thread Starter bobmorain

    (@bobmorain)

    Hi,

    Yes, the version is 1.1.0. I have found that each variation product must be updated in edit mode before the attribute name is displayed when selected. Somehow, the plugin only picks up attribute names for updated/newly-listed products.

    Of course for a store with hundreds of variation products there must be a more practical way of doing this rather than updating them one by one.

    Thank you.

    Hi @bobmorain

    Which version of WooCommerce are you using and is there any caching system enabled?

    Thanks

    Same issue as @bobmorain here.
    Some variations can’t be ordered anymore because of this.. cache is cleared. serverside and client side.
    Also the variations were re-saved.

    But still I am seeing undefined for a preselected default attribute.. and some colors can not be selected..

    HELP

    Thread Starter bobmorain

    (@bobmorain)

    Hi,

    I’m using Litespeed cache and Woocommerce 4.5.2. Cleaning the cache does not fix it. It seems the issue targets products randomly. For some products the variation label appears but for others its still undefined.

    @bobmorain

    Could you please update your WooCommerce to the latest version 4.7 and try to disable your all cache in system?

    Thanks

    I have the same problem – any fix for this?

    I could provide image og the problem if needed – but I think its well explained in the original question

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Undefined attribute name’ is closed to new replies.