WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Undefine variable iwp_action in WPBS V3.4.7

[Resolved] Undefine variable iwp_action in WPBS V3.4.7

Viewing 8 replies - 1 through 8 (of 8 total)
  • I get the same error message since updating to 3.4.7

    Also this:

    Warning: Cannot modify header information – headers already sent by (output started at /home/[…] /wp-content/plugins/better-wp-security/inc/secure.php:22) in /home/content/92/9531192/html/rwpdev/wp-includes/pluggable.php on line 876

    I have changed lines 15-26 of inc/secure.php to:

    //set a global variable if this is a call from InfiniteWP
    			$HTTP_RAW_POST_DATA = file_get_contents( 'php://input' );
    			$data = base64_decode( $HTTP_RAW_POST_DATA );
    			if ( $data && ($unserialized_data = @unserialize( $data ))) {
    				$iwp_action = $unserialized_data['iwp_action'];
    			}
    			if ( isset($iwp_action) ) {
    				$isIWP = true;
    			} else {
    				$isIWP = false;
    			}

    We’re seeing the same issue with this plugin. Is this on the official bug list yet?

    @joolee, was the change you made only to line 22?

    Original:

    if ( $iwp_action ) {

    Change:

    if ( isset( $iwp_action ) ) {

    This should be fixed in 3.4.8

    I also changed line 19 & 20 to:

    if ( $data && ($unserialized_data = @unserialize( $data ))) {

    This prevents the system from giving an error when updating a plugin. I don’t know the details of the problem but this seems to work.

    Up to the moment, the change that produced results was the one at lines 19 and 20:
    “if ( $data && ($unserialized_data = @unserialize( $data ))) {“

    Is there any official fix on this and/or offical feedback about this being the correct solution?!…

    Regards

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Undefine variable iwp_action in WPBS V3.4.7’ is closed to new replies.