Support » Fixing WordPress » Undeclared entity bug

  • Resolved jimiknightley


    Can anyone help me with this strange error message that occurs at the bottom of my blogg?

    Undeclared entity warning at line 247, column 1

    Don’t know how to fix it.


Viewing 15 replies - 1 through 15 (of 15 total)
  • Thread Starter jimiknightley


    I’ve got this as well – sorry Jimi, this isn’t a fix – can anyone shed any light?



    Having the same issue here,

    jimiknightley, did you find a solution? Ican’t see the error on your site now?

    Seems related to the plugin “Twitter for WordPress” which, after installing the error was introduced for me?


    Same issue, different line number

    Undeclared entity warning at line 227, column 1

    Changing “How many Twitter widgets would you like?” to 2 for displaying two twitter accounts shows the error twice.

    A Google search shows some other users have the problem with the Twitter for WordPress Widget.

    If it’s a plugin issue contact the author..

    Or post a link to the plugin here and i’ll take a look …

    Thanks T31os

    Twitter for WordPress

    I found the authors address in the readme.txt and will contact him.

    jimiknightley solved the problem by using a different widget.

    I can’t seem to replicate the problem..

    Where does this message appear for you?

    I’ve added 2 widgets, placed them in my left sidebar, both work as i’d expect…

    Line 227 is..
    function widget_twitter_page() {

    Which doesn’t make sense if that’s what the error relates to..

    The widget appeared to work except for the error message. The error message is the last text on the screen. I’m using the WordPress default theme with the sidebar on the right.

    Los Lunas Networks Test Blog is proudly powered by WordPress
    Entries (RSS) and Comments (RSS).
    Undeclared entity warning at line 227, column 1

    What file should I look at to see what is on line 227?

    I’d say (at a guess) it’s a theme file, normally error messages have the filename in the error message…

    Strange that one doesn’t … :-s

    I deactivated Twitter Widget Pro (works fine) and activated Twitter for WordPress and the error message returned.

    I changed the theme from WordPress Default to WordPress Classic and still got “Undeclared entity warning at line 227, column 1”.

    The only additional clue that I can provide is that the page displays and there is a delay before the error message displays. The error seems to occur late in the process of serving a page.

    I’m happy with Twitter Widget Pro and happy to move forward. I still hope to hear from the Twitter for WordPress widget author and will do more tests, if anyone has an idea of what to try. At this point, it looks like use the widget then get the error message.

    FYI,I’m using WordPress 2.7.1. I don’t know what version produced a line 247 error or no error. I can try other themes if there is a reason to believe the problem is theme related.

    Did you enable debugging in the config file?…

    It could just be the level of error reporting.

    >Did you enable debugging in the config file?…

    No, but I did some some googling and tried debugging. I got more error messages and looked at the twitter widget code. I don’t know PHP and only read a little widget code.

    I’m guessing that is my process of installing/uninstalling/re-installing multiple instances of the twitter widget, something got saved wrong or did not get cleared out in a config file. It is a big guess, but maybe the plugin code is looking for too many twitter user names. The code is trying to get/set options/defaults for a $username that is undefined because less widgets are actually installed.

    line 158 – undefined $username

    $messages = fetch_rss(‘’.$username.’.rss’);

    Lines 227 Undeclared entity warning and Line 228
    function widget_twitter_page() {
    $options = $newoptions = get_option(‘widget_twitter’);

    You need to enter a twitter account/username when creating a widget, i assume you did this…

    I’ve tried with one widget and with two. The account/username are correct and the tweets display on the sidebar. There is one instance of error message for ever instance of widget. The widget appears to work, but puts error message(s) at the bottom of the page. Remove the widget and the error messages go away. Reinstall/reactivate and the error messages return.

    The problem apparently doesn’t happen to everyone, but does happen to several people. I haven’t heard from the message I sent to the author. A different widget works without an error message.

    It’s strange because even with debugging on i get no such error…

    Did you have any problematic plugins or widgets installed previously?

    I know i’ve seen such errors when having problems with bad widgets.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Undeclared entity bug’ is closed to new replies.