Support » Plugin: The Events Calendar » Uncode Theme Compatibility Issues

  • zimmermo

    (@zimmermo)


    I seem to have a compatibility issue with the Uncode Theme. As you
    can see, the general events page looks off. There is this black empty
    header and then nothing for a while, and the event view starts only
    below that.

    Is there a way to fix this with Custom CSS?

    Happy for any feedback!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • I’m happy to pay whoever is able to fix this đŸ™‚

    Anyone?

    Plugin Author AndrĂ¡s Guseo

    (@aguseo)

    Hi @zimmermo

    Please check the following setting:
    Events > Settings > Display tab > Events Template

    Try changing that and see if that helps. It should work with ‘Default Events Template’.

    A.

    Dear Andras,

    Thank you so much for responding. Unfortunately, what happened when I followed your suggestion is that the page now seems to be in the correct layout, but for some reason the background is black but the skin is still light (so the text is black too). The same thing happens when I use Skeleton Layout. Any tips?

    Plugin Author AndrĂ¡s Guseo

    (@aguseo)

    Depends on what you’d like to achieve.

    This CSS snippet will give the calendar a white background:

    .tribe-common-l-container.tribe-events-l-container {
    	background-color: white;
    }

    You can put this under Appearance > Customize > Additional CSS, or in your child themes style.css file.

    A.

    Thank you again for your message, AndrĂ¡s! To answer your question, what I’d like to achieve is full and seamless compatibility of the plugin with the Uncode theme, as advertised by the plugin provider. đŸ™‚

    If you don’t mind, can you look on our page for a second? digitalsme.eu/virtual-events

    Your fix with additional CSS works for the width of the content, but the plugin has several more bugs. For example, the rest of the background is still black as you can see. None of the controls for List/Day/Month view or the manual change of the month work. When clicking on either of them, the site briefly loads a brighter background but nothing else happens. When clicking on the test event, the background of the content goes back to black.

    All I want is a simple calendar functionality that works with the Uncode theme. Would be wonderful if you could support us with this!

    Plugin Author AndrĂ¡s Guseo

    (@aguseo)

    Hi @zimmermo

    I checked your site and I see the issues. The URLs of the different views are not correct.

    Here’s what you can check as a start:

    – What permalink settings are you using? My guess is “post name”, that’s good. Try re-saving them and see if that helps.
    – Switch to a default theme like twentytwenty or twentysixteen and see if the view change works then.
    – Are you using a multilingual / language switcher plugin? (Those can unfortunately cause issues.) If yes, which one?

    The black background color is set by your theme in style-custom.css.
    You can override that with this snippet:

    body {
    	background-color: unset !important;
    }

    Hope this helps.
    Let me know what you find.

    Cheers,
    Andras

    Dear AndrĂ¡s,

    Once more, thank you for your support.

    1. I’m guessing you were talking about the URL slugs? I had “virtual-events” for both the general events page and the precursor to single events, but now changed it to “virtual-events” for the events page and “virtual-event/single-event/” as per the recommendation in the plugin to use plural for the former and singular for the latter. No change.
    2. I tried it in troubleshooting mode on Twenty Twenty. The view change didn’t work, but at least the background wasn’t black.
    3. Yes we are but it isn’t really active yet! We use WPML with a blog subscription currently.

    The black background colour only appears with this plugin, though. That’s strange, isn’t it? As you can see, we never use dark backgrounds for the entirety of a page on our website… Also, I don’t even use any custom CSS or only very little, so I don’t even really use a child theme. I think the mistake probably lies elsewhere and it would be great to find it!

    Cheers,
    Moritz

    Plugin Author AndrĂ¡s Guseo

    (@aguseo)

    HI @zimmermo

    I checked your site now and I could switch between the views without any difficulty.
    Did you manage to solve it somehow?

    Also, when you are changing the slugs, afterwards you need to re-save the permalinks under Settings > Permalinks to flush the old ones.

    And about the black background, this is where it’s set:
    https://dl.dropbox.com/s/l9en7mup7433qg0/shot_200518_212550.jpg

    which points to an asset in the theme.

    If you are not using a child theme then you can copy that CSS snippet under Appearance > Customize > Additional CSS.

    Hope this helps.
    Andras

    Hi AndrĂ¡s,

    I didn’t change anything! Now indeed the views-switch works, but the selection of months is still buggy… If you click on e.g. April and then on another month, it gets stuck displaying April and you have to use the arrows to change months again. Also, the month dropdown is somehow displayed behind the column designator for days…
    https://www.digitalsme.eu/digital/uploads/Events-Calendar-Bug.jpg

    I don’t see an option “Permalinks” in Settings. The search function seems to find one but it is hidden, I cannot see it.
    https://www.digitalsme.eu/digital/uploads/Events-Calendar-Bug2.mp4?_=2

    I applied the CSS snippet and now indeed the background color is inherited correctly. Still, I wonder how this incompatibility between the Uncode theme and the Events Calendar came about in the first place? Strange!

    Now if you can help me with the first bug I think we can actually use it!

    Again, thank you for your help throughout!

    Plugin Author AndrĂ¡s Guseo

    (@aguseo)

    Hi @zimmermo

    Sorry for the long pause, we got a bit busy and then side-tracked.

    Not sure why the dropdown goes behind. All the z-index values look good.
    Try adding this css:

    .tribe-events-calendar-month__header {
    	z-index: 999;
    }

    Permalinks is not a setting for TEC, it is a WordPress Setting. You will find it on the left side in the Settings menu. Here’s a screenshot:
    https://dl.dropbox.com/s/e44lgk7bagotcqc/shot_200626_225620.jpg

    Is there anything else?

    A.

    Dear Andras,

    Thank you for these tips! And thank you for getting back. I did not insist because I assumed you were as swamped as I am with all the chaos that’s currently happening around the world…

    There is indeed another, very important, issue. It seems that some of our events created through TEC show up in our custom “News & events” query, while others do not.

    Example of the only event that shows up: https://www.digitalsme.eu/untapped-potential-women-in-cybersecurity-digital-sme-live-conversation/

    Example of an event that doesn’t show up: https://www.digitalsme.eu/virtual-event/digital-sme-live-5g-opportunities-and-challenges-for-smes/

    If you could show me how I can make all of them show up in any query, that would be AMAZING (and also pretty core to the calendar functionality itself, I guess).

    Best regards,
    Moritz

    Plugin Author AndrĂ¡s Guseo

    (@aguseo)

    Hi @zimmermo

    Swamped indeed. đŸ™‚

    There is a setting to “Include events in main blog loop” under Events > Settings > General tab. Did you try that?

    A.

    Yes, that is activated and has been since the beginning. PLEASE mate, if you could help with that, I would be eternally grateful!

Viewing 15 replies - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.