Support » Plugin: Admin Bar Button » Uncaught TypeError: $.widget is not a function

Viewing 3 replies - 1 through 3 (of 3 total)
  • accapala

    (@accapala)

    I have the same error since i made the last update

    Plugin Author David Gard

    (@duck_boy)

    Hi lelandmarquess and accapala,

    Thanks for your feedback, however at present I’m unable to replicate the problem.

    From your description it seems that the script required for using the jQuery UI Widget Factory has not been included as required.

    My initial thought is that another plugin that you are using, or possibly your theme, is enqueueing a script and giving it the handle 'jquery-ui-widget', meaning that the correct script cannot be enqueued. However, without more information I cannot be sure.

    Troubleshooting

    First and foremost, I’m happy to say that I’ve literally just released version 4.0 of the plugin, which has reveived a lot of love and attention over the last few months. If you could please update to this version and try again, then post here with your results, I’d be grateful.

    If that doesn’t do the trick, please deactivate all other plugins and try again, and if that fails, please switch to the default TwentySixteen theme (don’t worry, you won’t lose any settings and can just switch back).

    If you do continue to encounter problems, could you please provide me with some additional details so that I can investigate further –

    • WordPress version – tested up to version 4.5.
    • Plugin version – hopefully the new version 4.0.
    • Theme name – I don’t know of any that cause a conflict, but there are literally thousands, plus you may be using a custom theme.
    • Other active plugins – There is always the possibility of incompatibilites, but I and other authors try very hard to minimise these.

    Thanks,
    David Gard

    I have replicated the problem and resolved it!!

    In the file abb-front.js

    replace $ with jQuery in lines: 11, 72, 73, 99, 330

    Before I did this, the bar did not work, revslider and visual composer were both broken. Now they work (in WP4.6)

    Trevor

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Uncaught TypeError: $.widget is not a function’ is closed to new replies.