Support » Plugin: ATUM Inventory Management for WooCommerce » Uncaught TypeError: Cannot call a class as a function sweetalert2.min.js?ver=1:1

  • Resolved shanedel90

    (@shanedel90)


    Hi,
    I am getting this console error whenever I try run a product export from the WooCommerce Quickbooks Connector by Techspawn plugin

    Disabling ATUM Inventory Management allows the export to run.

    This is the error
    https://prnt.sc/115xttm

    and this is the file in question.
    /wp-content/plugins/atum-stock-manager-for-woocommerce/assets/js/vendor/sweetalert2.min.js?ver=1.8.8

    I contacted the other plugin developer and they say its a ATUM Inventory issue.
    I was getting the same error from the Asset Cleanup plugin and the developer managed to fix the issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Salva Machi

    (@salvamb)

    Hi @shanedel90

    It seems there is a conflict on a 3rd party library that both plugins are using.
    The specific library is this one:
    https://sweetalert2.github.io/

    Perhaps that plugin is using an old version of the library and that is causing the issue. ATUM is using the latest version, so to avoid this conflict, they should try to upgrade to the latest version, I guess.

    Best Regards,
    Salva.

    Plugin Support andrearebel1

    (@andrearebel1)

    Hope all is well and ATUM is working faultlessly.

    We have not received any reply for more than a week, so we will close this post. If you need any further help, please, feel free to re-open it again.

    Best Regards,

    Andrea

    Thread Starter shanedel90

    (@shanedel90)

    They are using the latest library, and say its an issue with your implementation.
    I can send you a copy of this plugin so you can see the issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.