Support » Fixing WordPress » Uncaught TypeError after UPDATE

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Try going to Updates on the dashboard and clicking “reinstall wordpress”. maybe a file got corrupted during the update.

    thanks for reply
    I Reinstalled wordpress, but it did’t work
    still I have these errors

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins for you, while you’re still logged in, without affecting normal visitors to your site.

    deactivated all plugins, but still i have those errors
    errors appears only when I want to create or edit a post

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Please install the health check plugin and report back its findings: https://wordpress.org/plugins/health-check/

    PHP Version	 7.1.11
    MariaDB Server version	 10.1.24-MariaDB-cll-lve
    JSON Extension	 Your PHP install supports JSON.
    MySQL utf8mb4 support	 Your MariaDB version supports utf8mb4
    Communication with WordPress.org	 WordPress.org is reachable from your server.
    HTTPS status	 You are not using HTTPS to access this website.
    Secure communication	 Your WordPress install can communicate securely with other services.
    Scheduled events	 A scheduled event (wp_cache_gc) has failed to run. Your site still works, but this may indicate that scheduling posts or automated updates may not work as intended.
    Background updates	
     No version control systems were detected.
     Your installation of WordPress doesn't require FTP credentials to perform updates.
     All of your WordPress files are writable.
    Loopback request	 The loopback request to your site completed successfully.

    do you want debug info ?

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Try adding this to wp-config.php, before it says “stop editing”.

    
    define( 'CONCATENATE_SCRIPTS', false );

    debug info


    ### WordPress ###

    Version: 4.9.1
    Language: en_US
    Permalink structure: /%postname%/
    Is this site using HTTPS?: No
    Can anyone register on this site?: No
    Default comment status: open
    Is this a multisite?: No
    User Count: 1
    Communication with WordPress.org: WordPress.org is reachable
    Create loopback requests: The loopback request to your site completed successfully.

    ### Drop-ins ###

    advanced-cache.php: Advanced caching plugin.

    ### Active theme ###

    Name: Mundothemes
    Version: 5.0
    Author: Mundothemes Inc.
    Author website: https://mundothemes.com
    Parent theme: Not a child theme
    Supported theme features: post-thumbnails, menus

    ### Must Use Plugins (1) ###

    Health Check Disable Plugins: No version or author information available

    ### Active Plugins (2) ###

    Health Check: version 0.6.0 by The WordPress.org community

    ### Inactive Plugins (44) ###

    Ad Inserter: version 2.2.5 by Igor Funa
    Ajax Search Lite: version 4.7.10 by Ernest Marcinko
    WP Fastest Cache: version 0.8.7.4 by Emre Vona

    ### Server ###

    Server architecture: Linux 2.6.32-773.26.1.lve1.4.43.el6.x86_64 x86_64
    PHP Version: 7.1.11 (Supports 64bit values)
    PHP SAPI: litespeed
    PHP max input variables: 10000
    PHP time limit: 1300
    PHP memory limit: 1024M
    Upload max filesize: 1G
    PHP post max size: 1G
    cURL Version: 7.54.0 OpenSSL/1.0.2k
    SUHOSIN installed: No
    Is the Imagick library available: No

    ### Database ###

    Extension: mysqli
    Server version: 10.1.24-MariaDB-cll-lve
    Client version: 10.1.28-MariaDB
    Database prefix: wpyn_

    ### WordPress constants ###

    ABSPATH: /home/xxxx/public_html/www/
    WP_HOME: http://xxxxx.com
    WP_SITEURL: http://xxxxx.com
    WP_DEBUG: Disabled
    WP_MAX_MEMORY_LIMIT: 1024M
    WP_DEBUG_DISPLAY: Enabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Enabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined

    ### Filesystem permissions ###

    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    The Must Use Plugins directory: Writable

    added define( 'CONCATENATE_SCRIPTS', false );
    just before “That’s all, stop editing! Happy blogging”

    problem still exist..

    • This reply was modified 2 years, 2 months ago by saman27.
    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Is it the exact same problem though?

    Because if you actually added define( 'CONCATENATE_SCRIPTS', false ); to the wp-config.php file, then you would not see the load-scripts.php being used anymore. Because that is the script concatenator, and if you’ve turned that off, then it’s not there anymore.

    i think its wordpress bug as script errors are from “wp-includes” folder and not the theme

    its not from plugins as all plugins are disabled

    yeah exact same errors

    here is what my wp-config.php looks like

     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    //disable WP Post Revisions
    define('AUTOSAVE_INTERVAL', 300); // seconds
    define('WP_POST_REVISIONS', false);
    
    define('WP_DEBUG', false);
    define( 'CONCATENATE_SCRIPTS', false );
    /* That's all, stop editing! Happy blogging. */
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    Keith

    (@keithdriscoll)

    errors appears only when I want to create or edit a post

    As suggested, have you tried one of the WordPress default themes? It only takes a minute to do.

    BTW, what theme are you using? You didn’t provide a URL.

    Keith

    (@keithdriscoll)

    My bad…theme is named in checker 🙂

    But, it would be helpful to try a default theme.

    • This reply was modified 2 years, 2 months ago by Keith.
Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Uncaught TypeError after UPDATE’ is closed to new replies.