Support » Plugin: Address Autocomplete Using Google Place Api » Uncaught TypeError: a.widget is not a function

  • Uncaught TypeError: a.widget is not a function
    at menu.min.js:11
    at menu.min.js:11
    at menu.min.js:11
    autocomplete.min.js:11 Uncaught TypeError: a.widget is not a function
    at autocomplete.min.js:11
    at autocomplete.min.js:11
    at autocomplete.min.js:11

Viewing 1 replies (of 1 total)
  • @morettic, your errors are the same with mine after upgraded WP to 4.9.6. And i have fixed them by adding js libraries for them. I dont know the root cause, but i hope my fixing can help you:

    My issues:

    button.min.js?ver=1.11.4:formatted:29 Uncaught TypeError: a.widget is not a function
        at button.min.js?ver=1.11.4:formatted:29
        at button.min.js?ver=1.11.4:formatted:12
        at button.min.js?ver=1.11.4:formatted:13
    (anonymous) @ button.min.js?ver=1.11.4:formatted:29
    (anonymous) @ button.min.js?ver=1.11.4:formatted:12
    (anonymous) @ button.min.js?ver=1.11.4:formatted:13
    spinner.min.js?ver=1.11.4:11 Uncaught TypeError: a.widget is not a function
        at spinner.min.js?ver=1.11.4:11
        at spinner.min.js?ver=1.11.4:11
        at spinner.min.js?ver=1.11.4:11

    My fixing: add the code below at the bottom of functions.php file

    wp_enqueue_script('jquery-ui-button');
    wp_enqueue_script('jquery-ui-spinner');

    And your fixing should be the same:

    wp_enqueue_script('jquery-ui-menu');
    wp_enqueue_script('jquery-ui-autocomplete');
Viewing 1 replies (of 1 total)
  • The topic ‘Uncaught TypeError: a.widget is not a function’ is closed to new replies.