Support » Plugin: Business Directory Plugin | GeoDirectory » Uncaught TypeError

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Stiofan

    (@stiofansisland)

    Hi

    Under WP settings > AyeCode UI > check the default settings are set. If they are please provide your site URL and I will check the console log.

    Thanks,

    Stiofan

    Thread Starter dimal

    (@dimalifragis)

    Hello.

    Everything is default.

    Here is a staging link, valid for 2 days.

    https://www.temporary-url.com/A0EB

    Thank you

    Plugin Author Stiofan

    (@stiofansisland)

    Thanks for the info, it looks like your theme is also loading bootstrap.
    I have not tested this but i think this code snippet should work. You can either add it to a child theme functions file or use the “code snippets” plugin.

    add_action('wp_enqueue_scripts', 'my_disable_theme_bootstrap', 100);
    function my_disable_theme_bootstrap(){
    
    	wp_dequeue_script( 'bootstrap' );
    	wp_dequeue_style( 'bootstrap' );
    
    }

    Let me know how you get on.

    Thanks,

    Stiofan

    Thread Starter dimal

    (@dimalifragis)

    Hello.

    Using that snippet, brakes visually (and possible otherwise) the whole site.

    Plugin Author Stiofan

    (@stiofansisland)

    Ah sorry, i forgot to mention to put our bootstrap settings in “full mode” instead of compatibility mode. WP Settings > AyeCode UI > Frontend > Load CSS > Full Mode.

    That should fix things but if you have any issues let me know.

    Thanks

    Stiofan

    Thread Starter dimal

    (@dimalifragis)

    Well things got better, still some visual issues.

    But this error is still present:

    Uncaught TypeError: query_url is undefined
    /wp-content/plugins/geodirectory/assets/aui/js/map.min.js?ver=2.2.5:1
    build_map_ajax_search_param

    Uncaught ReferenceError: GeoDir_Business_Hours is not defined

    __

    I things are getting hairy, so maybe i should not use that plugin.

    Plugin Author Stiofan

    (@stiofansisland)

    hmm, i don’t see that error, what page do you see that on?
    I do see that the ninjafirewall plugin is blocking API requests so the map won’t load, maybe its releated.

    Thanks,

    Stiofan

    Thread Starter dimal

    (@dimalifragis)

    ok, thanks. I will spend today trying to figure this out. And update here.

    Plugin Author Stiofan

    (@stiofansisland)

    If you need further support feel free to open a ticket with our support team here: https://wpgeodirectory.com/support/

    Thanks,

    Stiofan

    Thread Starter dimal

    (@dimalifragis)

    I was able to fix all those issues, i hope this will not break the theme somewhere.

    Thank you for your help in this issue.

    • This reply was modified 2 months, 2 weeks ago by dimal.
    Plugin Author Stiofan

    (@stiofansisland)

    Awesome! 🙂

    If you hit any issues just let me know.

    Thanks,

    Stiofan

    Thread Starter dimal

    (@dimalifragis)

    One more question.

    I have found that if i enable in the ui Load JS-> Popper, everything works right, without the need to dequeue anything.

    Is that acceptable? I have used the plugin for an hour, added, deleted, changed, things, without any issues or errors anywhere.

    Plugin Author Stiofan

    (@stiofansisland)

    I think my original guidance is best as it would load less JS files but if you are having issues then yes it’s acceptable to do it that way.

    Thanks,

    Stiofan

    Thread Starter dimal

    (@dimalifragis)

    Using the dequeu method, i see some visual issues, like

    https://drive.google.com/file/d/11toYC0LzZMbqd6TZi7LBWhj3dFuzwdDs/view?usp=sharing

    Plugin Author Stiofan

    (@stiofansisland)

    OK that is strange, your theme version of bootstrap might be modified slightly, it might be required to load both.

    Stiofan

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.