Support » Plugin: WP Popups - WordPress Popup builder » Uncaught TypeError

  • Resolved stinamariechris

    (@stinamariechris)


    When I have this plugin activated, I’m getting a error “Uncaught TypeError: handler.selector is undefined” in my browser console. The pop up works fine. I’m using Be Theme and it looks as though there’s a conflict?

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter stinamariechris

    (@stinamariechris)

    Issue semi solved, it’s a conflict with BeTheme’s lightbox. I disabled lightbox in Betheme under Addons & Plugins > Addons.

    Plugin Author Damian

    (@timersys)

    Hi @stinamariechris,
    Not sure where that error is coming but I would need to see it in action. If you have a site for me to test, we could take alook

    Thread Starter stinamariechris

    (@stinamariechris)

    Hi @timersys
    It’s still happening on pages that use WP Bakery’s image gallery pop up.

    This is the error:

    Uncaught TypeError: handler.selector is undefined
        constructor /wp-content/themes/betheme/js/scripts.js?ver=25.1.4:1412
        setTimeout handler*constructor /wp-content/themes/betheme/js/scripts.js?ver=25.1.4:1404
        reload /wp-content/themes/betheme/js/scripts.js?ver=25.1.4:1427
        lightbox /wp-content/themes/betheme/js/scripts.js?ver=25.1.4:1442
        jQuery 8
        ajax /wp-content/plugins/js_composer/assets/js/dist/vc_grid.min.js?ver=6.7.0:10
        render /wp-content/plugins/js_composer/assets/js/dist/vc_grid.min.js?ver=6.7.0:10
        initStyle /wp-content/plugins/js_composer/assets/js/dist/vc_grid.min.js?ver=6.7.0:10
        <anonymous> /wp-content/plugins/js_composer/assets/js/dist/vc_grid.min.js?ver=6.7.0:10
        VcGrid /wp-content/plugins/js_composer/assets/js/dist/vc_grid.min.js?ver=6.7.0:10
        vcGrid /wp-content/plugins/js_composer/assets/js/dist/vc_grid.min.js?ver=6.7.0:10
        jQuery 2
        vcGrid /wp-content/plugins/js_composer/assets/js/dist/vc_grid.min.js?ver=6.7.0:10
        <anonymous> /wp-content/plugins/js_composer/assets/js/dist/vc_grid.min.js?ver=6.7.0:10
        jQuery 13
    Plugin Author Damian

    (@timersys)

    on which url I can see the error?

    Thread Starter stinamariechris

    (@stinamariechris)

    On pages that use WP Bakery’s lightbox in an image gallery:

    https://feastcaterers.com/teresa-and-joes-spring-wedding-colors/

    Plugin Author Damian

    (@timersys)

    I see you are using siteground optimizer that concatenates all files. Could you disable that to see if the error persists?

    Thread Starter stinamariechris

    (@stinamariechris)

    @timersys It persists when I turn it off. You can take a look at my test site, it has no caching: https://feast.christinaschneider.com/teresa-and-joes-spring-wedding-colors/

    Plugin Author Damian

    (@timersys)

    Thanks for that but the error seems to be on their side.

    Instead of
    if( handler && handler.selector.indexOf(‘lightbox’) !== -1 ){

    They should use

    if( handler && handler.selector && handler.selector.indexOf(‘lightbox’) !== -1 ){

    That way they check if selector is defined before doing a indexOf and the error will go away.

    Thread Starter stinamariechris

    (@stinamariechris)

    Is this in the WP Bakery file or Be Theme?

    The error goes away if I deactivate WP Popups.

    Plugin Author Damian

    (@timersys)

    wp-content/themes/betheme/js/scripts.js line 1412

    Thread Starter stinamariechris

    (@stinamariechris)

    @timersys Thank you! I reported the issue to BeTheme and they will be making your change in the next update.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Uncaught TypeError’ is closed to new replies.