Support » Plugin: WP Activity Log » Uncaught TypeError

  • Resolved mrfranta

    (@mrfranta)


    Hi, I had to deactivate all plugins because of some “bug” in some plugin. Then when I tried to activate this plugin again, i got:
    Fatal error: Uncaught TypeError: Argument 1 passed to WSAL_ViewManager::AddInstance() must be an instance of WSAL_AbstractView, instance of WSAL_Views_SetupWizard given, called in C:\inetpub\weby\jiskraplavani\wp-content\plugins\wp-security-audit-log\classes\ViewManager.php on line 134 and defined in C:\inetpub\weby\jiskraplavani\wp-content\plugins\wp-security-audit-log\classes\ViewManager.php:142 Stack trace: #0 C:\inetpub\weby\jiskraplavani\wp-content\plugins\wp-security-audit-log\classes\ViewManager.php(134): WSAL_ViewManager->AddInstance(Object(WSAL_Views_SetupWizard)) #1 C:\inetpub\weby\jiskraplavani\wp-content\plugins\wp-security-audit-log\classes\ViewManager.php(125): WSAL_ViewManager->AddFromClass('WSAL_Views_Setu...') #2 C:\inetpub\weby\jiskraplavani\wp-content\plugins\wp-security-audit-log\classes\ViewManager.php(93): WSAL_ViewManager->AddFromFile('C:\\inetpub\\weby...') #3 C:\inetpub\weby\jiskraplavani\wp-content\plugins\wp-security-audit-log\wp-security-audit-log.php(190): WSAL_ViewManager->__construct(Object( in C:\inetpub\weby\jiskraplavani\wp-content\plugins\wp-security-audit-log\classes\ViewManager.php on line 142

    I cannot fix it even with installation and uninstallation. Any idea?

    • This topic was modified 2 years, 6 months ago by mrfranta.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Contributor robertabela

    (@robert681)

    Hello @mrfranta,

    The error seems to be generated because you are running the website on an IIS web server. Below are some questions which will help us troubleshoot the issue:

    – Are you running a hosted server or on Azure?
    – What version of Windows and IIS are you running?
    – What version of WordPress are you running?
    – Did you run previous versions of the plugin or this is the first time you installed it?

    Looking forward to hearing from you.

    Thread Starter mrfranta

    (@mrfranta)

    plugin version : 3.2.3

    1. Hosted server
    2. I cannot tell you now… When I will be able to reach the ftp again, i will try to run php info
    3. 4.9.8–cs_CZ
    4. It run well until yesterday

    As I wrote, the plugin worked ok, but I updated some plugin and whole pages got broken, so I disabled all plugins using the SQL:
    SELECT * FROM wp_options WHERE option_name = 'active_plugins';

    Then I started to turn on manually all plugins and your plugin stopped work 🙁

    • This reply was modified 2 years, 6 months ago by mrfranta.

    Hello,

    Updating IIS user here as well.. since the last update it broke my site so I had to disable the plugin manually.

    1. Hosted
    2. Windows NT 10.0 build 14393 (Windows Server 2016) AMD64 / Microsoft-IIS/10.0
    3. $wp_version = ‘4.9.8’; / $wp_db_version = 38590;
    4. I was running this plugin fine, untill the latest update broke it.

    If there is any more information that might help, let me know!

    Plugin Contributor robertabela

    (@robert681)

    HI @wizzard_

    Can you:

    1) Disable all active plugins again
    2) Activate our plugin
    3) Start activating the other plugins one by one. Take a note of the last plugin you activated before the error happened.

    Let me know what that plugin is so we can try to reproduce the issue in our test environment.

    Disabled all plugins. When I try to reactivate WP Security Audit Log I immediately get the same error again:

    Plugin could not be activated because it triggered a fatal error.

    So this doesn’t seem to be caused by interference from other plugins.

    Having same issue and leaving plugin manually disabled until it is fixed.

    Plugin Contributor robertabela

    (@robert681)

    Hello @samuraiprojects

    The issue here is related to hosting on Windows. Is your setup on Windows as well? If not please open a separate support ticket.

    Plugin Contributor robertabela

    (@robert681)

    Hello @mrfranta and @wizzard_

    What database server are you using please for your setup?

    I, too, am getting this error. It started immediately after update to version 3.2.3 on my test server.

    I am running my test server on a Hyper-V Windows 10 using the WAMP stack.
    WP 4.9.8
    PHP 7.0.10
    MySQL 5.7.14
    Apache 2.4.23

    I disabled by renaming the plugin’s directory on the server.

    Error messages and call stack
    ( ! ) Fatal error: Uncaught TypeError: Argument 1 passed to WSAL_ViewManager::AddInstance() must be an instance of WSAL_AbstractView, instance of WSAL_Views_SetupWizard given, called in C:\wamp\www\xxxxxxxx.com\wp-content\plugins\wp-security-audit-log\classes\ViewManager.php on line 134 and defined in C:\wamp\www\xxxxxxxx.com\wp-content\plugins\wp-security-audit-log\classes\ViewManager.php on line 142
    ( ! ) TypeError: Argument 1 passed to WSAL_ViewManager::AddInstance() must be an instance of WSAL_AbstractView, instance of WSAL_Views_SetupWizard given, called in C:\wamp\www\xxxxxxxx.com\wp-content\plugins\wp-security-audit-log\classes\ViewManager.php on line 134 in C:\wamp\www\xxxxxxxx.com\wp-content\plugins\wp-security-audit-log\classes\ViewManager.php on line 142
    Call Stack
    # Time Memory Function Location
    1 0.0009 413600 {main}( ) …\admin.php:0
    2 0.0012 427656 require_once( ‘C:\wamp\www\xxxxxxxx.com\wp-load.php’ ) …\admin.php:31
    3 0.0017 440976 require_once( ‘C:\wamp\www\xxxxxxxx.com\wp-config.php’ ) …\wp-load.php:37
    4 0.0026 529448 require_once( ‘C:\wamp\www\xxxxxxxx.com\wp-settings.php’ ) …\wp-config.php:106
    5 0.4650 31461024 include_once( ‘C:\wamp\www\xxxxxxxx.com\wp-content\plugins\wp-security-audit-log\wp-security-audit-log.php’ ) …\wp-settings.php:305
    6 0.5139 34989504 WpSecurityAuditLog::GetInstance( ) …\wp-security-audit-log.php:1329
    7 0.5139 34989904 WpSecurityAuditLog->__construct( ) …\wp-security-audit-log.php:158
    8 0.5187 35134272 WSAL_ViewManager->__construct( ) …\wp-security-audit-log.php:190
    9 0.5365 36077328 WSAL_ViewManager->AddFromFile( ) …\ViewManager.php:93
    10 0.5365 36077368 WSAL_ViewManager->AddFromClass( ) …\ViewManager.php:125
    11 0.5387 36191104 WSAL_ViewManager->AddInstance( ) …\ViewManager.php:134

    Thread Starter mrfranta

    (@mrfranta)

    Hi,

    here I gathered some info from phpinfo and phpmyadmin:

    Server info: Microsoft-IIS/8.0
    PHP Version 7.0.14
    System 	Windows NT VPSFC7185 6.2 build 9200 (Windows Server 2012 Standard Edition) AMD64 
    
    MySQL:
    Server version: 5.6.33-log - MySQL Community Server (GPL)
    Protocol version: 10
    Version of db client: libmysql - mysqlnd 5.0.12-dev - 20150407 - $Id: 241ae00989d1995ffcbbf63d579943635faf9972 $

    Here is something which I gathered from Ultimate member plugin:

    --- Web Server Configurations ---
    
    PHP Version:              			7.0.14
    MySQL Version:            			5.6.33
    Web Server Info:          			Microsoft-IIS/8.0
    
    --- PHP Configurations ---
    
    PHP Memory Limit:         			256M
    PHP Upload Max Size:      			20M
    PHP Post Max Size:        			8M
    PHP Upload Max Filesize:  			20M
    PHP Time Limit:           			300
    PHP Max Input Vars:       			1000
    PHP Arg Separator:        			&
    PHP Allow URL File Open:  			Yes
    
    --- Web Server Extensions/Modules ---
    
    DISPLAY ERRORS:           			N/A
    FSOCKOPEN:                			Your server supports fsockopen.
    cURL:                     			Your server supports cURL.
    SOAP Client:              			Your server has the SOAP Client enabled.
    SUHOSIN:                  			Your server does not have SUHOSIN installed.
    GD Library:               			PHP GD library is installed on your web server.
    Mail:                     			PHP mail function exist on your web server.
    Exif:				          PHP Exif library is NOT installed on your web server.
    
    --- Session Configurations ---
    
    Session:                  			Enabled
    Session Name:             			PHPSESSID
    Cookie Path:              			/
    Save Path:                			C:\\Windows\\Temp\\
    Use Cookies:              			On
    Use Only Cookies:         			On
    
    --- WordPress Active Plugins ---
    
                    AccessPress Facebook Auto Post: 2.0.2
    Akismet Anti-Spam: 4.0.8
    Cookie Notice: 1.2.44
    Duplicate Post: 3.2.2
    Insert Headers and Footers: 1.4.3
    Media Library Folders for WordPress: 4.2.4
    Restrict User Access: 1.0.1
    TablePress: 1.9
    TinyMCE Advanced: 4.8.0
    Ultimate Category Excluder: 1.1
    Ultimate Member: 2.0.23
    WP Google Map Plugin: 4.0.6
    WP Mail SMTP: 1.3.3
    WP Super Cache: 1.6.3
    Yoast SEO: 8.0
    Zalomení: 1.4.7

    Please notice, that I’m not owner of the server, I’m using provided hosting -> I cannot simply change anything in the configuration etc.

    • This reply was modified 2 years, 6 months ago by mrfranta.
    • This reply was modified 2 years, 6 months ago by mrfranta.
    Plugin Contributor robertabela

    (@robert681)

    Thanks for all the info. Definitely this is something related to running the plugin on a Windows platform. We are doing some tests and will get back to you shortly.

    Plugin Contributor robertabela

    (@robert681)

    Hello @mrfranta @mikemeinz @samuraiprojects @wizzard_

    I can confirm the issue and we can reproduce it in our test environment. We are working on a fix right now and should releases a hotfix very soon.

    Sorry for the inconvenience caused.

    No problem, good to see you’re acting so fast on it 🙂

    Plugin Contributor robertabela

    (@robert681)

    We have just released version 3.2.3.1, which is a hotfix for this issue.

    Thank you all for reporting the issue and sorry for the inconvenience. Do not hesitate to get in touch should you require any further assistance.

    Thank you for using the plugin.

    1. Renamed the plugin directory back to wp-security-audit-log.
    2. Installed the version 3.2.3.1 plugin update.
    3. Activated the WP Security Audit Log plugin.

    Working fine now.

    Thanks!

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Uncaught TypeError’ is closed to new replies.