Support » Plugin: Lightweight Accordion » Uncaught SyntaxError: Block missing from the block editor

  • Resolved giannisdallas

    (@giannisdallas)


    Hello and thank you for the plugin,

    I get an error when trying to add blocks

    Uncaught SyntaxError: Identifier '__' has already been declared in the first line of the index.js file.

    The shortcode works just fine. Also, when I deactivate all other plugins I can see the block.

    Can you please help me?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Andy Feliciotti

    (@someguy9)

    Hey @giannisdallas, what version of WordPress are you using?

    Thread Starter giannisdallas

    (@giannisdallas)

    Hey Andy

    Current version: 5.7.2
    GeneratePress Premium with 20 plugins.

    Everything but Perfmatters pro plugin is up to date

    Thank you
    Giannis

    • This reply was modified 11 months, 2 weeks ago by giannisdallas.
    Plugin Author Andy Feliciotti

    (@someguy9)

    @giannisdallas, the first line of the index.js for lightweight accordion doesn’t declare __ (line 3 does) so I am thinking the error may be another plugin.

    Thread Starter giannisdallas

    (@giannisdallas)

    Hey Andy,

    I am sharing two screenshots to see that the error is actually on the accordion’s file

    https://imgur.com/6975HlE
    https://imgur.com/kejIVQQ

    How odd, really.
    Do you have any idea how to investigate further? When I deactivate everything else it works but it stops working after activating other plugins – not the same one unfortunatelly.

    Thank you very much
    Giannis

    • This reply was modified 11 months, 2 weeks ago by giannisdallas.
    Plugin Author Andy Feliciotti

    (@someguy9)

    @giannisdallas mind sending me a full list of your plugins? Or the one that you think is triggering the conflict?, thanks for the screenshots I’ll get to the bottom.

    Thread Starter giannisdallas

    (@giannisdallas)

    Not at all:

    Advanced Gutenberg Blocks
    GP Premium
    Gravity Forms
    Gravity Forms AWeber Add-On
    Gravity Forms Mailchimp Add-On
    Imagify
    Lightweight Accordion
    MemberMouse Platform
    Nested Pages
    Perfmatters
    PNG to JPG
    Redirection
    Relevanssi
    Testimonials Showcase
    WebP Express
    WP Rocket
    WP Sitemap Page
    WP Video Lightbox
    WP YouTube Lyte
    Yoast SEO
    YourChannel

    The last time I checked the error went away after deactivation GForms, but reappeared when I activated the remaining plugins.

    Thank you

    Plugin Author Andy Feliciotti

    (@someguy9)

    Getting the error with Gravity Forms as well, I’ll see what I can do to make the error go away in version 1.6 🙂

    Thread Starter giannisdallas

    (@giannisdallas)

    Great!

    Let me know if you need anything else.

    Cheers

    Plugin Author Andy Feliciotti

    (@someguy9)

    @giannisdallas the latest update (1.5.7) should fix this bug, let me know if it fixes it for you!

    Thread Starter giannisdallas

    (@giannisdallas)

    Hi Andy, sorry for the late reply,

    Had a chance to try the plugin again and I see no issues.

    Thanks once again

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Uncaught SyntaxError: Block missing from the block editor’ is closed to new replies.