Support » Plugin: Simply Static » Uncaught Runtime Exception with 2.1.2.

  • Resolved ckranebitter

    (@ckranebitter)


    Hi Patrick,

    first of all, thanks for the wonderful plugin.
    Everything worked fine with 2.1.1.
    But with 2.1.2. a get a Runtime Exception when generating the Zip-File.
    It looks as if Static has a problem with another Plugin (Essential-Grid):

    Can you please have a look and fix this?
    I attached the last lines of the Debug-Protokoll
    Thanks.
    Christoph.

    [2021-02-11 11:43:23] [class-ss-fetch-urls-task.php:106] Extracting URLs and replacing URLs in the static file
    [2021-02-11 11:43:23] [class-ss-archive-creation-job.php:326] Fehler: (1) Uncaught RuntimeException: Not valid HTML fragment!a.eg-henryharrison-element-1%2Ca.eg-henryharrison-element-2%7B-webkit-transition%3Aall.4slinear%3B-moz-transition%3Aall.4slinear%3B-o-transition%3Aall.4slinear%3B-ms-transition%3Aall.4slinear%3Btransition%3Aall.4slinear%7D.eg-jimmy-carter-element-11i%3Abefore%7Bmargin-left%3A0px%3Bmargin-right%3A0px%7D.eg-harding-element-17%7Bletter-spacing%3A1px%7D.eg-harding-wrapper.esg-entry-media%7Boverflow%3Ahidden%3Bbox-sizing%3Aborder-box%3B-webkit-box-sizing%3Aborder-box%3B-moz-box-sizing%3Aborder-box%3Bpadding%3A30px30px0px30px%7D.eg-harding-wrapper.esg-media-poster%7Boverflow%3Ahidden%3Bborder-radius%3A50%25%3B-webkit-border-radius%3A50%25%3B-moz-border-radius%3A50%25%7D.eg-ulysses-s-grant-wrapper.esg-entry-media%7Boverflow%3Ahidden%3Bbox-sizing%3Aborder-box%3B-webkit-box-sizing%3Aborder-box%3B-moz-box-sizing%3Aborder-box%3Bpadding%3A30px30px0px30px%7D.eg-ulysses-s-grant-wrapper.esg-media-poster%7Boverflow%3Ahidden%3Bborder-radius%3A50%25%3B-webkit-border-radius%3A in <b>/var/www/html/wp-content/plugins/simply-static/vendor/voku/simple_html_dom/src/voku/helper/SimpleHtmlDom.php</b> on line <b>176</b>
    [2021-02-11 11:43:23] [class-ss-archive-creation-job.php:268] Status message: [error] Fehler: (1) Uncaught RuntimeException: Not valid HTML fragment!a.eg-henryharrison-element-1%2Ca.eg-henryharrison-element-2%7B-webkit-transition%3Aall.4slinear%3B-moz-transition%3Aall.4slinear%3B-o-transition%3Aall.4slinear%3B-ms-transition%3Aall.4slinear%3Btransition%3Aall.4slinear%7D.eg-jimmy-carter-element-11i%3Abefore%7Bmargin-left%3A0px%3Bmargin-right%3A0px%7D.eg-harding-element-17%7Bletter-spacing%3A1px%7D.eg-harding-wrapper.esg-entry-media%7Boverflow%3Ahidden%3Bbox-sizing%3Aborder-box%3B-webkit-box-sizing%3Aborder-box%3B-moz-box-sizing%3Aborder-box%3Bpadding%3A30px30px0px30px%7D.eg-harding-wrapper.esg-media-poster%7Boverflow%3Ahidden%3Bborder-radius%3A50%25%3B-webkit-border-radius%3A50%25%3B-moz-border-radius%3A50%25%7D.eg-ulysses-s-grant-wrapper.esg-entry-media%7Boverflow%3Ahidden%3Bbox-sizing%3Aborder-box%3B-webkit-box-sizing%3Aborder-box%3B-moz-box-sizing%3Aborder-box%3Bpadding%3A30px30px0px30px%7D.eg-ulysses-s-grant-wrapper.esg-media-poster%7Boverflow%3Ahidden%3Bborder-radius%3A50%25%3B-webkit-border-radius%3A in <b>/var/www/html/wp-content/plugins/simply-static/vendor/voku/simple_html_dom/src/voku/helper/SimpleHtmlDom.php</b> on line <b>176</b>

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter ckranebitter

    (@ckranebitter)

    Hi Patrick,

    any news on this one?
    Can you please email me the 2.1.1-Version so that I can at least do my exports?

    Many thanks.
    Best.
    C.

    Plugin Author patrickposner

    (@patrickposner)

    Hey @ckranebitter,

    I added the issue to the Github repository and will check that, but it will not happen soon.

    The problem is that Essential Grids seems to generate invalid HTML within their output which will be ignored in Simply Static to prevent any issues in the static output (this also prevents from executing hacked code for example.).

    You can download the older version here: https://downloads.wordpress.org/plugin/simply-static.2.1.0.zip

    Best regards,
    Patrick

    Thread Starter ckranebitter

    (@ckranebitter)

    Hi Patrick,

    thanks for the update.
    I tried to install 2.1.0 but the activated Plugin-Version just gives me a greyed-out screen.
    Can you please also provide 2.1.1. as with this version everything worked for me.

    Thanks in advance.
    Best.
    C.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.