Support » Plugin: Yoast SEO » Uncaught ReferenceError: yoastWebpackJsonp is not defined

  • Resolved prihodslnk

    (@prihodslnk)


    Привествую!
    После обновления плагина вылезла ошибка
    Uncaught ReferenceError: yoastWebpackJsonp is not defined
    at wp-seo-replacevar-plugin-790.min.js:1
    /wp-content/plugins/wordpress-seo/js/dist/wp-seo-replacevar-plugin-790.min.js

    _http://prntscr.com/ke87mk

Viewing 13 replies - 1 through 13 (of 13 total)
  • Idem !

    I have the same problem. How to fix this ASAP?

    Plugin Support Jerlyn

    (@jerparx)

    Unfortunately, we are unable to replicate the issue from our end. Can you please confirm if you are using the latest Yoast SEO 7.9, WordPress 4.9.8 and the latest version of your theme? What triggers the error? Does the issue happen even when using the default WP theme?

    Same Problem Here

    Uncaught ReferenceError: yoastWebpackJsonp is not defined at wp-seo-replacevar-plugin-790.min.js?ver=7.9:1

    Yoast SEO Premium – Version 7.9
    Wordpress – Version 4.9.8

    How to fix issue ASAP?

    • This reply was modified 2 years, 2 months ago by nskaik.

    @jerparx You likely have a Git hub versioning push to svn issue.
    Your trunk on git hub does not match svn. Also your RC1 branch was partial merged with 7.9X which means your internally running code that is not available to the worls thru the WordPress update feature.

    ya might want to merge tickets all recent ones are related to this.

    yup, i Got same problem, Seo Yoast cenot edit meta title and description like this http://prntscr.com/kesi19 … but work well if use Gutenberg Editor.

    Yeah, same here

    Uncaught ReferenceError: yoastWebpackJsonp is not defined
    at wp-seo-replacevar-plugin-790.min.js?ver=7.9:1

    The box remains blank..

    • This reply was modified 2 years, 2 months ago by paul2411.

    The problem is solved by disabling the Gutenberg.

    Disabling Gutenberg does not work for me, still blank meta title and description box

    MariusG

    (@marius_codeinwp)

    Hey guys,

    Thank you for reporting this issue, we’re sorry for the troubles. Upon further investigation, we found that this issue happens when both Gutenberg and Classic Editor plugins are active. When deactivating either of the 2 plugins, Yoast SEO seems to be working as expected.

    We have opened a GitHub issue and sent it to our development team, they will provide a solution as soon as possible. In the meantime, you can follow the progress or let us know if you have any other information here.

    Plugin Support Michael Tina

    (@mikes41720)

    Please update to the latest version of Yoast SEO for WordPress v8.0 and this should be fixed accordingly. Setting to resolved.

    Same problem here.
    Wordpress version: 4.9.9

    /* resolved */
    if ( ! function_exists( ‘disable_gutenberg’ ) ) {
    function disable_gutenberg() {

    global $wp_filter;

    $callbacks_array = $wp_filter[‘init’]->callbacks;

    foreach( $wp_filter as $tag => $priorities ) {
    foreach( $priorities->callbacks as $priority => $callback_data ) {
    foreach( $callback_data as $callback_function_name => $callback_function_data ) {

    if ( strpos( $callback_function_name, ‘disable_gutenberg’ ) !== false ){
    continue;
    }

    // Gutenberg disabler
    if ( strpos( $callback_function_name, ‘gutenberg’ ) !== false || strpos( $callback_function_name, ‘block_editor’ ) ){

    remove_filter( $tag, $callback_function_name, $priority );

    }

    }
    }
    }

    $wp_filter[‘init’]->callbacks = $callbacks_array;

    add_filter( ‘use_block_editor_for_post_type’, ‘__return_false’ );
    }
    }
    add_action( ‘admin_init’, ‘disable_gutenberg’ );

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Uncaught ReferenceError: yoastWebpackJsonp is not defined’ is closed to new replies.