WordPress.org

Forums

WooCommerce - excelling eCommerce
Uncaught ReferenceError: woocommerce_params is not defined (5 posts)

  1. Tech4Eleven
    Member
    Posted 1 year ago #

    Im using the latest version of WooCommernce and Chrome Developer tools is reporting

    "Uncaught ReferenceError: woocommerce_params is not defined" in woocommerce.min.js:1 and I think its keeping other javascript from running properly. The theme developer said they never touched woocommerce code, just provided styling for it.

    See screenshot. can you help please?

    http://blackhillshabitat.org/

    Screenshot: http://take.ms/DadzL

    http://wordpress.org/extend/plugins/woocommerce/

  2. Roy Ho
    Member
    Posted 1 year ago #

    Do you have some sort of caching/pagespeed plugin? Turn that off and see if it fixes it.

  3. Tech4Eleven
    Member
    Posted 1 year ago #

    I do now yes - cloudflare. This error existed before I signed up with cloudflare though.

  4. Roy Ho
    Member
    Posted 1 year ago #

    Is cloudflare what is generating those "pagespeed" files?

  5. Tech4Eleven
    Member
    Posted 1 year ago #

    yes. they're cached now.

  6. Roy Ho
    Member
    Posted 1 year ago #

    That's the only thing I can think of that is causing it. This is assuming you've already tried the compatibility test of turning off all plugins except WC and switching to default 2012 theme.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.