Support » Plugin: Fast Velocity Minify » Uncaught ReferenceError: jQuery is not defined

  • Resolved andrea.cinque

    (@andreacinque)


    Hello there!
    Let me first thank you for your precious work because with your plugin I’ve reached a 98% Page Speed grade in almost one click. Very appreciated!

    WordPress 5.0.3 | Avada 5.7.2

    My issue is that I can’t set it properly. Here’s the problem:
    If I just activate the plugin, I’ll get 98% grade on page speed but my embedded videos on the page and revolution slider don’t work.

    This is the message: “Uncaught ReferenceError: jQuery is not defined” and a screenshot.
    https://imgur.com/a/1AbV93Y

    So I tried all these fixes (from FAQs and other topics) with no success:

    – Enable Skip deferring the jQuery library
    – Adding jquery folder to ignore list (/wp-includes/js/jquery/) – as written on the faqs this should ignore entire folder, am I right?
    – Enable defer of all JS files for PSI only
    – Install autoptmize and let it handle the js stuff

    The only setting that works is “Disable JavaScript processing”, but this turn on again videos and revolution slider but my page score goes down to an F grade.

    So, I am kindly asking support for this assuming it’s only a setting/click to let it work properly.

    Currently, I’ve disabled Javascript processing in order to have the website looking good for our clients.

    Thanks in advance for your support

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • G

    (@gnetworkau)

    Try again: Adding jquery folder to ignore list
    then
    Make sure the following is unchecked:
    Settings > Skip deferring the ignore list

    andrea.cinque

    (@andreacinque)

    Thanks G for your feedback.
    I’ve solved my issue by adding the jquery folder to ignore list with this path:

    //www.mysite.com/wp-includes/js/jquery

    Unchecked on Settings > Skip deferring the ignore list

    Then this didn’t help me too much, so I’ve activated on PageSpeed Settings
    – Enable defer of all JS files for PSI only
    – Exclude JS files in the “ignore list” from PSI

    I don’t know if this is the right way to solve it, but it works for me.
    Hope this can be helpful for others.

    All the best

    G

    (@gnetworkau)

    Glad you solved it.
    Maybe I should have said to make sure that it is checked (not unchecked):
    Settings > Skip deferring the ignore list

    Double negatives sometimes confuse me…

    That setting would be clearer for me if it was opposite:

    Settings > Defer files in the ignore list

    Plugin Author Raul P.

    (@alignak)

    Thanks for the feedback 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Uncaught ReferenceError: jQuery is not defined’ is closed to new replies.