Support » Plugin: Easy Social Post Feed - Social Photos Gallery - Page Plugin - Auto PopUp - MT » Uncaught reference error: FB is not defined

  • Resolved genpepe

    (@genpepe)


    When I load the page with the Easy Facebook Likebox widget on the blog sidebar I have this error:
    Uncaught ReferenceError: FB is not defined
    at HTMLDocument.<anonymous> (public.js?ver=4.3.3:9)
    at i (jquery.js?ver=1.12.4:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
    at Function.ready (jquery.js?ver=1.12.4:2)
    at HTMLDocument.K (jquery.js?ver=1.12.4:2)

    And, I imagine as a consequence, the menu and the “latest posts” widget don’t work.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Danish Ali Malik

    (@danish-ali)

    Hi @genpepe,

    Hope you will be fine 🙂

    I just checked your shared URL and it’s working fine.

    Maybe you were using the older version of the plugin.

    Thanks!

    Hi @danish-ali, I still see the problem.
    This is the screenshot of the page with the web console showing the error message

    Gennaro

    Plugin Author Danish Ali Malik

    (@danish-ali)

    Hi @genpepe,

    I just checked your shared URL and it feeds are loading perfectly and there is not any error like this Uncaught ReferenceError: FB is not defined check out the Screenshot.

    Maybe you are your site is using browser cache please check in incognito mode.

    Thanks!

    In your screenshot there’s a red alert with a ‘1’ on the right. It’s related to the error I’m seeing. It should appear in your console as it appears in mine. The error is hidden by filters, if you uncheck the filters (console settings) you’ll see it.
    I tried with Firefox clearing the cache and the resul i the same, as you can see in this screenshot

    • This reply was modified 1 year, 10 months ago by  genpepe.

    Same js error here. It came through the Easy Facebook Feed widget, which I finally removed. It made not possible to use the normal website js functionality related to menus…

    I also disabled the widget and now the page works perfectly. I’m not so happy to not have the widget on my blog page, but this seems to be the only solution at the moment thanks @joseluiscruz

    I am getting this same error and it’s causing my Envira Galleries to not work properly. As soon as I disable this plugin, the errors went away and my Galleries started to work properly again.

    Same issue here. If ‘Easy Facebook Feed’ widget is activated on my Instagram feed page then my Instagram Feed plugin will stop working. No pictures whatsoever, only loading symbol is shown. When I removed the ‘Easy Facebook Feed’ widget from the page then everything on that page works normal again. Thanks.

    Plugin Author Danish Ali Malik

    (@danish-ali)

    Hi there,

    I have just released the new version of the plugin.
    Delete the existing plugin and install the updated version.

    Hope it will work for you guys Thanks!

    Sorry, I have uninstalled 4.3.3 and installed 4.3.4 but I have still the same problem:
    JQMIGRATE: Migrate is installed, version 1.4.1
    public.js:10 Uncaught ReferenceError: FB is not defined
    at HTMLDocument.<anonymous> (public.js:10)
    at i (jquery.js:2)
    at Object.fireWith [as resolveWith] (jquery.js:2)
    at Function.ready (jquery.js:2)
    at HTMLDocument.K (jquery.js:2)

    Hi @danish-ali,

    Thanks for the update but unfortunately the issue remains on my website. 🙁
    Cheers.

    Plugin Author Danish Ali Malik

    (@danish-ali)

    Please share the site URL

    The page is the same that I posted some weeks ago.
    The problem is with all the pages where I use the widget, for instance: http://test.buonmercato.info/wpbckp/blog/orto-collettivo/

    • This reply was modified 1 year, 10 months ago by  genpepe.

    You can find it as a widget: http://www.dawiels.com/menu/
    and on a regular page: http://www.dawiels.com/dawiels-on-facebook/
    The Instagram plug-in (as a widget on the right hand sidebar) will stop working due to this error (loading symbol). On other pages I used another Facebook plug-in as a widget and it works fine with the Instagram plug-in.

    Yes, we have the same issue at 4.3.4

    Please add fbAsyncInit function in the first statement in public.js to load the FB event when FB is initiated.

    window.fbAsyncInit=function() {
    if ($(".efbl_feed_wraper .efbl_custom_likebox")[0] || $(".widget_easy_facebook_page_plugin .efbl-like-box")[0] ){
    
    			    FB.Event.subscribe('xfbml.render', function(response) {
    			    	var animclasses = $('.efbl-like-box .fb-page').data('animclass');
    			    	
    			    	$('.efbl-loader').remove();
    
    			    	$('.efbl-like-box iframe').addClass('animated ' + animclasses);
    			    	
    			    });
    
    		    }
    	}
    

    This works fine.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Uncaught reference error: FB is not defined’ is closed to new replies.