Support » Plugin: Post SMTP Mailer/Email Log » Uncaught Error: Undefined class constant ‘VERSION’

  • Resolved tlozano

    (@tlozano)


    First, Thank you for this plugin, it is very good.

    I have a problem with “Post SMTP Mailer/Email Log”. It works fine, but if I use “mailerlite” integration with woocommerce, I get an error and no more emails are sending.
    Is I use “Mailerlite plugin” without woocommerce integration, it works fine.

    This is the error trace in server:
    [error] FastCGI sent in stderr: “PHP message: PHP Fatal error: Uncaught Error: Undefined class constant ‘VERSION’ in /home/user/web/xxxx.com/public_html/wp-content/plugins/post-smtp/Postman/Postman-Mail/google-api-client/vendor/google/apiclient/src/Google/Client.php:1042
    Stack trace:
    #0 /home/user/web/xxxx.com/public_html/wp-content/plugins/post-smtp/Postman/Postman-Mail/google-api-client/vendor/google/apiclient/src/Google/Client.php(1032): Google_Client->createDefaultHttpClient()
    #1 /home/user/web/xxxx.com/public_html/wp-content/plugins/post-smtp/Postman/Postman-Mail/google-api-client/vendor/google/apiclient/src/Google/Client.php(356): Google_Client->getHttpClient()
    #2 /home/user/web/xxxx.com/public_html/wp-content/plugins/post-smtp/Postman/Postman-Mail/google-api-client/vendor/google/apiclient/src/Google/Client.php(786): Google_Client->authorize()
    #3 /home/user/web/xxxx.com/public_html/wp-content/plugins/post-smtp/Postman/Postman-Mail/google-api-client/vendor/google/apiclient/src/Go” while reading response header from upstream, client: xx.xx.xx.xx, server: xxxx.com, request: “POST / HTTP/1.1”, upstream: “fastcgi://unix:/run/php/php7.4-fpm-xxxx.com.sock:”, host: “xxxx.com”, referrer: “https://xxxx.com/”`

    Any ideas about this error?

    Thank you.

    • This topic was modified 2 months, 1 week ago by tlozano.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter tlozano

    (@tlozano)

    Ok, I have more info.
    It fails only with Gmail API config. With SMTP config works fine.
    So, I have disable Gmail API and check SMTP and now it is working fine.

    Plugin Author yehudah

    (@yehudah)

    Thank you for the update.

    I am getting the same error with VERSION constant. I found that it conflicts with other plugin “AWS for WordPress” (Amazon Polly) plugin. “GuzzleHttp\ClientInterface” same package is also used in it. What could be the solution?

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.