Support » Plugin: Locations and Areas - Leaflet Map with Region Tabs » Uncaught Error: Invalid LatLng object: (NaN, NaN)

  • Resolved Richzendy

    (@richzendy)


    Hi! first thanks for the plugin.

    I have a error clicking the tabs, the error is:

    Uncaught Error: Invalid LatLng object: (NaN, NaN)
        j https://dui-sv.com/wp-content/plugins/locations-and-areas/src/leaflet/leaflet.js?x31303&ver=5.5.1:5
        W https://dui-sv.com/wp-content/plugins/locations-and-areas/src/leaflet/leaflet.js?x31303&ver=5.5.1:5
        project https://dui-sv.com/wp-content/plugins/locations-and-areas/src/leaflet/leaflet.js?x31303&ver=5.5.1:5
        flyTo https://dui-sv.com/wp-content/plugins/locations-and-areas/src/leaflet/leaflet.js?x31303&ver=5.5.1:5
        onclick https://dui-sv.com/home-2/:969
        EventHandlerNonNull* https://dui-sv.com/home-2/:957
        <anonymous> https://dui-sv.com/home-2/:956

    is weird, all locations are showed fine on the map.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author 100plugins

    (@100plugins)

    Hi Richzendy,
    sorry for the delay. I will look into it right now!

    Plugin Author 100plugins

    (@100plugins)

    Right now the map on your page doesn’t work at all. Did you try to change something to make it work? And did you try to disable Caching/Minify Plugins?

    Your described error happens when you did add Areas but did not provide lat and lng fields for each. So please fill out lat and lng fields for Areas as well and it should work. I will fix this in the next update!

    Did this solve your problem?

    Thread Starter Richzendy

    (@richzendy)

    Thanks for your response.

    Yes i can disable but just a few moment because is a production site, but that was tested before and without minify is the same problem.

    these are my locations: https://imgur.com/a/TRJfQ5W

    location;area;lat, long
    Usulután;Usulután;13.345322, -88.442741
    Soyapango;San Salvador;13.703791, -89.150848
    Sonsonate;Sonsonate;13.731905, -89.715675
    Sensuntepeque;Cabañas;13.87737, -88.62677
    Santiago de María;Usulután;13.484374, -88.466194
    San Vicente;San Vicente;13.642351, -88.78949
    San Miguel;San Miguel;13.483826, -88.178581
    San Francisco Gotera;Morazán;13.696735, -88.102356
    Lourdes;La Libertad;13.742669, -89.361893
    Cojutepeque;Cuscatlán;13.720723, -88.933975
    La Unión;La Unión;13.336975, -87.845055
    Chalatenango;Chalatenango;14.039439, -88.938202
    Apopa;Apopa;13.791298, -89.174623
    Ahuachapán;Ahuachapán;13.920203, -89.844963
    Santa Tecla;Santa Tecla;13.673754, -89.289185
    Centro San Salvador;Centro San Salvador;13.698091, -89.189512
    San Salvador – CC Galerías;San Salvador;13.702341, -89.229042
    Santa Ana;Santa Ana;13.984271, -89.566856
    Zacatecoluca;La Paz;13.507725, -88.87104
    Mejicanos;San Salvador;13.730219, -89.221742

    Plugin Author 100plugins

    (@100plugins)

    Thanks for your feedback. Your locations look fine, but you have to setup coordinates for the “Areas” also. In wordpress backend please click on submenu item “Areas” and edit “Ahuachapán” for example. Fill in “13.926142” for lat and “-89.845356” for lng and “11” for zoom and save. You have to do this for every Area to make them clickable.

    The other issue (map doesnt load) is connected to caching. Please try to avoid inline JS caching with your caching plugin, as this breaks the logic of loading the map.

    I will fix both issues in upcoming update.

    • This reply was modified 1 year, 8 months ago by 100plugins.
    Plugin Author 100plugins

    (@100plugins)

    Hey richzendy,
    I fixed both issues in todays update (Version 1.0.3). But please remember that you will have to fill in coordinates for Areas as I described before.

    Please let me know if this solves your issues.

    (and if so, it would really help us to get a positive review from you 🙂 )

    • This reply was modified 1 year, 8 months ago by 100plugins.
    Thread Starter Richzendy

    (@richzendy)

    Hi! Sorry about delay.

    Yes the lat and long on the areas was missing.

    Are working now.

    Thank you so much.

    Plugin Author 100plugins

    (@100plugins)

    Great! Thanks for your input, every little solved issue does make the plugin better. Some review from you would be very helpful.

    Cheers from Berlin, Daniel

    Plugin Author 100plugins

    (@100plugins)

    Hey Richzendy. Vertical Areas navigation is now available. You can select that in the new “Layout”-Setting. Maybe that’s interesting to you. Have a good one, Daniel

    Thread Starter Richzendy

    (@richzendy)

    Hi! thanks a lot, i’m glad to hear about this, have a nice day, i’m trying later upgrade the plugin and test this.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Uncaught Error: Invalid LatLng object: (NaN, NaN)’ is closed to new replies.