Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Uncaught Error: Class ‘Automattic\Jetpack\Third_Party\domain_map’

  • Resolved slightlydifferent

    (@slightlydifferent)


    In the latest version we are seeing:

    Fatal error: Uncaught Error: Class ‘Automattic\Jetpack\Third_Party\domain_map’ not found in /home/webeasy/webapps/webeasy/wp-content/plugins/jetpack/3rd-party/class-domain-mapping.php:156 Stack trace:
    #0 /home/webeasy/webapps/webeasy/wp-content/plugins/jetpack/3rd-party/class-domain-mapping.php(101): Automattic\Jetpack\Third_Party\Domain_Mapping->get_domain_mapping_utils_instance()
    #1 [internal function]: Automattic\Jetpack\Third_Party\Domain_Mapping->hook_wpmu_dev_domain_mapping()
    #2 /home/webeasy/webapps/webeasy/wp-content/plugins/jetpack/3rd-party/class-domain-mapping.php(68): call_user_func()
    #3 /home/webeasy/webapps/webeasy/wp-includes/class-wp-hook.php(287): Automattic\Jetpack\Third_Party\Domain_Mapping->attempt_to_hook_domain_mapping_plugins()
    #4 /home/webeasy/webapps/webeasy/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters()
    #5 /home/webeasy/webapps/webeasy/wp-includes/plugin.php(484): WP_Hook->do_action()
    #6 /home/webeasy/webapps/webeasy/wp-settings.php(420): do_action()
    #7 /home/webeasy/webapps/webeasy in /home/webeasy/webapps/webeasy/wp-content/plugins/jetpack/3rd-party/class-domain-mapping.php on line 156

    Fix is line 160 of 3rd-party/class-domain-mapping.php change from:

    return domain_map::utils();
    to
    return \domain_map::utils();

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Jen H.

    (@jenhooks)

    Hey @slightlydifferent,

    Can you please deactivate and delete Jetpack entirely, and then reinstall it?

    You can delete Jetpack from your Plugins page in WP Admin. Then, you can reinstall from the Plugins page as well. Here’s our guidance on doing this, if you need it:

    http://jetpack.me/support/installing-jetpack/

    Then, reconnect to Jetpack.

    If you still have trouble, could you please post your site URL here, so we can do some targeted troubleshooting?

    Thanks!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thanks for the report! That does indeed seem related to some changes we’ve made in the latest version of Jetpack, and your proposed fix should solve the issue. We’ll make sure to include the fix in the next version of Jetpack.

    You can follow our progress on this here:
    https://github.com/Automattic/jetpack/pull/18323

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    We’ve just released Jetpack 9.3.1 to address this issue. Everything should now be back to normal once you update to that new version of Jetpack.

    Sorry for the trouble!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.