Support » Alpha/Beta/RC » Uncategorized Cat added on import using 4.7RC

  • Resolved Pioneer Web Design

    (@swansonphotos)


    Note that the import was done in phpMyAdmin from a phpMyAdmin Export. The version in use (installed after DB import) was two versions back.

    All my posts had the uncategorized category added to them. I have fixed manually, but just wanted to note this.

    Anyone else see this?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    You replaced the database you mean? PhpMyAdmin is direct sql stuff, so it shouldn’t add anything since you’re replacing the Db.

    If you tried to merge the db then I could see issues like that happening, depending on your current set up.

    It was a direct import in phpMyAdmin, not a merge, a brand new DB. Then I installed WP and saw the uncategorized cat.’s for posts that did not exist and do not exist in the export file.

    Moderator Marius L. J.

    (@clorith)

    Could you share with us the exact version numbers in play here, and the steps you took when doing this, as you mention you installed WordPress. This could mean you just manually edited the wp-config file wth the details, or you ran the actual installer (the latter would indeed create Uncategorized as it’s the default category in WordPress and is created on install, and is expected behavior).

    I imported the export (both using phpMyAdmin) of an existing site that had many posts, none had uncategorized cat.’s. Then I ran install.php

    Per the version.php of the download I used to install:

    
    $wp_version = '4.7-beta4';
    $wp_db_version = 38590;
    $tinymce_version = '4403-20160901';
    

    Note: on the site used for export, none of the published posts had ‘uncategorized’, 4 draft posts did.

    Hmmm…

    Moderator Marius L. J.

    (@clorith)

    What about the version you were copying the data from?

    
    $wp_version = '4.6.1';
    $wp_db_version = 37965;
    $tinymce_version = '4401-20160726';
    
    Moderator Marius L. J.

    (@clorith)

    When you ran install.php, did you get a warning that WordPress was already installed, or did it go through all the steps to set up your admin user etc after supplying the database credentials?

    I just did the same upgrade and am not seeing any new categories introduced so long as you supply the same credentials and DB prefix so I’m curious about what screens you were brought through.

    Moderator Marius L. J.

    (@clorith)

    As we’ve been unable to reproduce anything here, and haven’t heard back in a few days, I’ll be marking the thread as resolved.

    We mark topics as resolved when there’s either a ticket assigned to it, there hasn’t been any reporter feedback in a while, or when the next version of WordPress comes out.

    Thanks for the help with this and sorry for not getting back right away – was busy and now even busier checking out and testing WP4.7.

    Just had similar experience while importing WordPress XML from old website to WordPress 4.7 (final release).
    Data was exported using default WordPress export tool from WordPress 3.8.16 . On 4.6.1 all posts are imported in correct categories as they were on old website.
    Today I tried importing same XML into WordPress 4.7 and all posts have their original category and “Uncategorized”.
    Import on both versions was done using the same WordPress Importer 0.6.3
    Is this WordPress bug, or should I report it to WordPress Importer plugin support?

    Having the same issue. Looks like it has been reported here as a bug:

    https://core.trac.wordpress.org/ticket/39301

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Please don’t post in the Alpha/Beta forum unless you’re actually testing the alpha/beta version of WordPress (not a plugin or a theme). Also, once WordPress has released a version, it’s not appropriate to post in alpha/beta and you should post in the How To & Troublshooting forum:

    https://wordpress.org/support/forum/how-to-and-troubleshooting

    This post has been closed.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Uncategorized Cat added on import using 4.7RC’ is closed to new replies.