Unattached images during wordpress database import (4 posts)

  1. lydia86
    Posted 5 years ago #

    Hi there,
    I recently migrated from a wordpress.com blog to a self-hosted wordpress.org blog. The URL to the website is http://wordlesstech.com/
    I exported the old blog's content in xml format and then imported it in the new one. I ticked the box import images and download files when prompted. The problem now is that the images in the posts still have the old URL. After using the search and replace plugin http://wordpress.org/extend/plugins/search-and-replace/ in order to replace the images old URLs with the new URLs the images still appear to be unattached in the Media Library even though the link in the posts points to the images in the new .org blog. Can anyone help please? There are thousands of posts on the website and so I can not manually attach all the images... Is there a better way?
    Thanks for you help!

  2. alfh
    Posted 5 years ago #

    Same problem here, although I have a number of posts actually possible to manage manually if really needed. Images still have the old url, and are listed as unattached in the media library.

  3. alfh
    Posted 5 years ago #

    In this post, http://wordpress.org/support/topic/automatically-import-linked-images-files-to-media-library there's a recommendation for a plugin fixing some of this problem.

  4. Tim Griffin
    Posted 4 years ago #

    I've posted some of my trial with this same issue here:

    Basically, I've now imported multiple xml export files from a WordPress.com site to a self-hosted site.

    The media imports to the new install.
    The status of being attached to a specific post failed.

    Some 816 images imported - but 624 show their status as unattached.
    Only 5 images are unattached on the blog I am exporting from.

    How to fix...
    Is there a media library fix to cycle through the images and use the attachment data included in the export file?

    I even tried an export of just the media into the WXR format and still the same result.


Topic Closed

This topic has been closed to new replies.

About this Topic