Support » How-To and Troubleshooting » Unable to upload to wp

Unable to upload to wp

  • Hi, Hope i am posting in correct section
    i have searched for weeks for a solution to my problem

    On many of my sites since i upgraded wp to its current version i have received warnings making it impossible to upload plugins, themes, media, etc
    tried changing /tmp to tmp but said already exists
    saw to change permission to 777 but i am on 755 as would think only user would need to write
    the errors i receive are
    Warning: touch() [function.touch]: Unable to create file /home2/timheath/public_html/wp-content/uploads/double-opt-in-for-download.tmp because No such file or directory in /home/timheath/public_html/wp-admin/includes/file.php on line 179

    Warning: unlink(/home2/timheath/public_html/wp-content/uploads/double-opt-in-for-download.tmp) [function.unlink]: No such file or directory in /home/timheath/public_html/wp-admin/includes/file.php on line 493
    Download failed. Destination directory for file streaming does not exist or is not writable.

    so im guessing im on the right track with the tmp file but would love if someone could use their expert knowledge to help me solve this problem
    Thanks in advance

Viewing 14 replies - 1 through 14 (of 14 total)
  • Try reinstalling WordPress manually from a freshly downloaded copy except wp-content. Do not overwrite files/ folders but delete them before reinstalling.
    Use FTP or your hosting control panel if you cannot access dashboard.
    Backup your site including database so that you can restore in case anything goes wrong.

    thanks for quick reply
    i tried as you said but have the same errors/warnings as before.
    I have read to try change /tmp to tmp but it said file already exists.
    should i try changing tmp to /tmp?????

    the warning i receive trying to upload a plug in is
    Downloading install package from http://downloads.wordpress.org/plugin/wp-db-backup.2.2.3.zip…

    Warning: touch() [function.touch]: Unable to create file /home2/timheath/public_html/wp-content/uploads/wp-db-backup.tmp because No such file or directory in /home/timheath/public_html/wp-admin/includes/file.php on line 179

    Warning: unlink(/home2/timheath/public_html/wp-content/uploads/wp-db-backup.tmp) [function.unlink]: No such file or directory in /home/timheath/public_html/wp-admin/includes/file.php on line 493
    Download failed. Destination directory for file streaming does not exist or is not writable.

    thanks in advance

    The plugin wp-db-backup has not been updated for more than two years. There is an yellow warning box at the top of the page. That may be the reason why you get error messages. Do you have problem while uploading other plugins?

    yes that was just an example same warning if i try to upload any plugin or any theme

    someone told me it could be a file path problem???

    line 179 of file.php is

    line 493 is
    unlink( $tmpfname );

    does that help?

    It’s a core file. That’s why I suggested to reinstall WordPress manually except wp-content. Have you tried that?

    thanks for the help
    yes i have tried reinstalling wordpress twice except for the wp-content
    the last time i only had a wp-config-sample.php so i deleted that and uploaded an old wp-config.php file i had downloaded a few days earlier

    someone said when i upgraded wordpress to 3.5 my old config file was not compatible so should i be creating a new config file?
    or something to do with the path?
    from what ive been reading somewhere i saw wp 3.5 didnt have something and so should create a new tmp file or something?
    i tried creating a tmp file with permission 755 (tried 777 too) in uploads folder but that hasnt worked either

    Can you link to your site?

    sure me site is linked to previous my site

    you can see any errors
    originally there were warnings displayed on web page but after disabling a plug in it dissappeared but cant upload plugins/themes now

    Try these steps:
    – deactivate all plugins. Then activate one by one and look for errors until you locate the problematic one.
    – If the above step does not help, revert to Twenty Twelve theme and see if if you can upload any new plugins

    tried deactivating all plugin still received same warning with all plugins deactivated
    tried reverting to twenty twelve with all plugins deactivated reverted fine to twenty twelve but still same warning when i go to upload a plugin
    exact same warning as mentioned earlier

    Try changing permissions for wp-content directory to 766. If you still errors, try 767, 775 or 777. Once you can upload, change permission for wp-content back to 755 and check if everything still works fine.

    permission of wp-content was on 755 tried it on 777 and 766 not luck
    do you want me to try 767 and 775 seems futile if other didnt work
    if tried changing permissions on various folders previously but to no avail

    Now I guess that the problem can be some server configurations. Following the recent Brute Force attacks, several hosts have reconfigured their servers. So, you need to contact your hosts.

    so should i ask them to change permission of my uploads folder?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Unable to upload to wp’ is closed to new replies.