Support » Fixing WordPress » Unable to upload pic

  • Resolved ivobol


    Hi There!

    Since I have upgraded to WP 2.2 I cannot upload pictures, error message:
    “Unable to create directory /var/www/vhosts/ Is its parent directory writable by the server?”

    I noticed that it is the first time there is a folder:
    before that pics were always put in:

    Does it have to do with file permissions? How can I change this in fireftp, anyone?

    Sorry if I sound a bit stupid or ignorant and thanks!


Viewing 5 replies - 1 through 5 (of 5 total)
  • I recently upgraded to 2.3, and indeed it now puts pictures in yearly & monthly subdirectories, so that part is normal.

    I did not have to set or adjust write-permissions for the new image-directories. WP has done that on it’s own (including the /10 subdir that went up since the /9 upgrade).

    I use FileZilla to poke around in my Host directories, and set/reset permissions if/when needed. If I had the error you are reporting, I’d use FTP to check those settings.

    I am quite ignorant, extensively inexperienced, and my tinyMCE is banging off the walls … but I’m still pushing pics up onto the Host, and havin’ fun. 😉

    Thanks for the reply…I have tried Filezilla, changed all the folders’ permision to 777, still the same problem…i am at a loss…


    You don’t necessarily have to accept the year/month schema in uploads. If you go to Options | Miscellaneous, you will note a checkbox there with:

    Organize my uploads into month- and year-based folders

    Some people prefer just “one big directory” yet others clearly prefer the built in organizer, splitting all your images into months.

    Concerning whether or not the web server is able to write to var/www/vhosts/
    Your error message clearly says:
    “Is its parent directory writable by the server?”
    Two things you must check:
    1. Owner/group of the uploads directory (and all below it)
    What your local web server needs for owner/group is somewhat variable. It could be “www/www” or “root/root” or “apache/apache” – check your httpd.conf for owner/group and try changing to whatever is set in httpd.conf. That’s one approach anyway.
    2. Whether the directory permissions are correctly set (as you remarked in your post). Try easing off the permissions like this

    chmod -R 777 uploads

    “R” is for recursive (meaning all directories below uploads)
    That’s and an extremely liberal permissions set, but later you can always experiment with tightening things up bit by bit until it’s set securely enough yet still allows uploading. If you get the ownership and permissions correct so you can actually do stuff, then (later) try tightening uploads to 775 using the same method as described above.

    Sometimes it takes a bit of trial and error, but use these guidelines and you should be on the right track.

    Regards & HTH

    Thanks for the input.

    The error I get is:

    “Unable to create directory /var/www/vhosts/ Is its parent directory writable by the server?
    Back to Image Uploading”

    All the subdirectories are chmod 777, and I can upload picture with FTP and adjust the code (so I guess the Owner and group permissions are ok) but I cannot use the WordPress editor. I can just carry on wth my Blog using ftp, but it is still a mystery…

    WP 2.2 created a yearly based structure for storing uploads. When I changed this back thru Options | Miscellaneous / Organize my uploads into month- and year-based folders OFF I had no more problems with uploading.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Unable to upload pic’ is closed to new replies.