Support » Requests and Feedback » Unable to upload photo’s

  • After selecting a photo, press upload.
    Instead of the picture ,I see a message-
    The uploaded file could not be moved to——

Viewing 4 replies - 1 through 4 (of 4 total)
  • I am getting this same error. All the folders have write access but I cant see how it is failing. Perhaps its a problem with the write permissions of the tmp folder? Im using a linux based server through Media Temple if that helps.

    OK. I fixed my problem. I set write permissions to the upload folder, but I needed to set it on the wp-content folder as well for some reason.
    Also, this was originally an issue with the wp-ecommerce plugin (coldnt upload photos for products) but setting permissions for the plugins folder to 777 fixed that too.
    Not the most secure but its the only thing that worked.




    Volunteer Moderator

    Some servers require you to change file permissions to 777 from 755 for your upload folder depending on how you set it up in your settings e.g.
    = wp-content/uploads/2008/10 — the /10 folder CHMOD to 777
    = wp-content/uploads — the /uploads folder CHMOD to 777

    I checked all of the folders in the path. They all have 777 properties. I even changed the root to 777, even that did not have an effect.

    The only way I can get it to work, is delete the from WP created folder and create a folder manually. I can then change the properties manually. Then it works.

    There is a basic problem here, as I have also noticed that publishing a post runs forever. If I then stop the action in the browser and reload the page, publishing works almost instantly.

    At the moment I am having some real problems with customer sites, because of these problems.

    If anyone has an idea how I can solve these problems, I would appreciate the help.


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Unable to upload photo’s’ is closed to new replies.