WordPress.org

Support

Support » Alpha/Beta » [Resolved] Unable to upload media in Fullscreen mode

[Resolved] Unable to upload media in Fullscreen mode

  • Hi there,

    Have installed RC2. In fullscreen (distraction free writing) mode the media upload button isn’t working. This is both in HTML and Visual versions. I click the button and nothing happens. There is no problem with the help popup window – and no problem inserting images when not in fullscreen mode.

    Have tried this out on local install and on shared hosting.

    Bug? Or just me being dumb?

Viewing 11 replies - 1 through 11 (of 11 total)
  • It’s working fine for me, What browser & operating system are you using? Have you tried another browser at all?

    Also, What about plugins?

    Tried on two computers – PC with Windows 7, laptop with windows Vista Business.

    Tried Chrome, Firefox, IE8

    No plugins installed.

    Moderator kmessinger

    @kmessinger

    Also works for me, Windows 7, IE9 and FF5, Atahaulpa theme. Maybe a theme thing?

    raggedrobins —

    Have you tried the default theme?

    Moderator Andrew Ozz

    @azaozz

    WordPress Dev

    The upload/insert button in DFW is very simple, all it does is jQuery('#add_image').click();, i.e. clicks the “normal” Add Image button that’s above the “normal” editor.

    If one is working the other should work too (unless there’s a plugin that modifies the normal Add Image button and changes/removes the HTML id).

    I just managed to confirm this issue on a fresh multisite subdirectory install.

    This is what I did:
    1) Installed fresh WP, all defaults, no plugins.
    2) Tested the upload in DFW mode – it worked as it should.
    3) Activated network.
    4) Created a post and switched to DFW mode.
    5) “Insert/Edit image” button stopped responding.

    Tested in FF5, IE8, Opera 11.5 and Chrome 12.

    Thanks for responding guys.
    I’ve set up a fresh install on my server.

    The image upload is working fine on single site but not on MS with a subdirectory install. The help button still works.

    I have no plugins installed. I have tried both Twenty Ten and Twenty Eleven themes.

    Alright, I think the issue here is that in multisite, you need to turn on the various media buttons in Network > Settings.

    So the bug would be that we have to check the network setting before showing the image button.

    Yes, this is probably right, as when I switched to Network I had no #add_image link. Switching back to single mode brought it back: http://i51.tinypic.com/2rhtg0n.png

    Alternatively, you could trigger the click event on #add_media, as I had that one by default.

    Closing this thread as it has been confirmed that the issue was network activation, not dfw.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Unable to upload media in Fullscreen mode’ is closed to new replies.
Skip to toolbar